[sane-devel] Issue with libsane 1.0.27+git20170719-xenial0 and Canon PIXMA MX495

Olaf Meeuwissen paddy-hack at member.fsf.org
Wed Aug 2 12:11:01 UTC 2017

Hi Jean,

Since I got mentioned by name ;-), you may want to look into using git's
bisect subcommand.  If that sounds/looks to complicated, you can do it
by hand as well.  First find the sha1-id for the version that works for
you.  Then using that sha1-id, create a list of the ones you might need
to check with

  git log --oneline <sha1-id>..HEAD -- backend/pixma*

Then check out the sha1-id in the middle, check whether that works.  If
it does, you can drop the bottom half of you list.  If it doesn't, you
can drop the top half.  Repeat this until you find the first sha1-id for
which things no longer work for you after the one for which things still

I just ran the above command for the sha1-id corresponding to our 1.0.25
release and there are only ten changes to the pixma code.  So at worst,
you need to try four times.  It's a bit faster than doing them one at a
time ;-)

# Apologies if you already know what bisecting is.

Rolf Bensch writes:

> Hi Jean,
> If you like, you can install SANE from the git repository as described
> in INSTALL.linux (http://sane-project.org/docs.html) to find the problem
> in the source code.
> Most interesting are the commits from the master branch containing
> changes for files starting with pixma after 27.05.2017. Usually these
> commits come from Olaf Meeuwissen or from me. Please checkout these
> commits, compile and test them. Easy to use git frontends are git-gui,
> gitk or gitg. But you must checkout a commit with its sha1-id from the
> command line (the 1st 6 to 7 characters of the sha1-id are enough to
> identify the commit), e.g.:
> $ git checkout  c2594e
> Note: checking out 'c2594e'.
> You are in 'detached HEAD' state. You can look around, make experimental
> changes and commit them, and you can discard any commits you make in this
> state without impacting any branches by performing another checkout.
> If you want to create a new branch to retain commits you create, you may
> do so (now or later) by using -b with the checkout command again. Example:
>   git checkout -b <new-branch-name>
> HEAD ist jetzt bei c2594e9... Revert "pixma_imageclass.c: MF240 Series
> supports only 300dpi for adf scans"
> Please report the branch which 1st produces the problems you've reported
> before.
> Otherwise we must wait some weeks finding the problem commit.
> Hope this helps.
> Cheers,
> Rolf
> Am 25.07.2017 um 23:03 schrieb Jean Cérien:
>> Hi Rolf,
>> First, thank you for looking into this.
>> Second, there is no rush, as I have a workaround reverting to 1.0.25,
>> I've tried with sane-release ppa,
>> scanimage (sane-backends) 1.0.27git; backend version 1.0.27
>> and it works fine
>> same with sane-test, which is ok,
>> I've reverted to sane-git, and it fails again.
>> Let me know if you need more info,
>> J.
>> On Tue, Jul 25, 2017 at 3:59 AM, Rolf Bensch <rolf at fam-bensch.de
>> <mailto:rolf at fam-bensch.de>> wrote:
>>     Hi Jean,
>>     Please try my other ppa's (SANE Release and SANE Test) with older
>>     versions of SANE: https://launchpad.net/~rolfbensch
>>     <https://launchpad.net/%7Erolfbensch> and report the
>>     results. Then I'll have an idea where to search for the issue you
>>     reported.
>>     Please be patient. I'm on the move until end of August and I have less
>>     time to work on SANE.
>>     Hope this helps.
>>     Cheers,
>>     Rolf
>>     Am 19.07.2017 um 23:22 schrieb Jean Cérien:
>>     >
>>     > Hello
>>     > I have a multifunction canon pixma mx 495. Up
>>     > to 1.0.25+git20150528-1ubuntu2, I only had one small issue, the ADF
>>     > wasnt working, but flatbed was ok.
>>     >
>>     > Since 1.0.27+git20170719-xenial0, in flatbed mode, I can only scan on
>>     > page and then I get an error:
>>     > scanimage: sane_read: Error during device I/O
>>     >
>>     > after scaning one page, trying to scan a second.
>>     >
>>     > Reverting to 1.0.25 restore the previous way of working and allows me
>>     > to scan multiple pages via flatbed.
>>     >
>>     > scanimage -L gives:
>>     > device `pixma:04A91787' is a CANON Canon PIXMA MX490 Series
>>     > multi-function peripheral
>>     >
>>     > I've tried 1.0.27 with  /etc/sane.d/pixma.conf from 1.0.25, but
>>     > unfortunately, that does not work.
>>     >
>>     > As an FYI, the ADF reports 'Operation was cancelled' in 1.0.25 and .27
>>     >
>>     > Thanks for any help to have this scanner keep on working,
>>     >
>>     > Rgds J.

Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list