[sane-devel] sane-backend 1.0.27 USB broken on Mac with Homebrew

schmo-fu schmo-fu at feinfug.org
Thu Jul 27 19:38:59 UTC 2017

Hi Tom,

you would have to install homebrew (see https://brew.sh/)

After that you simply type "brew install sane-backends" this will
install a binary (called bottle). The binaries are installed to
/usr/local/Cellar/... and symlinked /usr/local/bin/

To compile your own brew (after changing something in the formula for
example) you would enter "brew install --build-from-source sane-backends".

The formula is a ruby-file found at:

You probably know how to test whether it finds any scanners, but anyway:
you use "sane-find-scanner -v" and "scanimage -L".

(aka schmo-fu)

Am 27.07.17 um 21:02 schrieb Tom Myers:
> I have a 10000XL I can test with with if there is a 1.0.27 built for macintosh.  Just yell where I can download it.
>> On Jul 27, 2017, at 12:14 PM, schmo-fu <schmo-fu at feinfug.org> wrote:
>> Hey Olaf and Yurii,
>> thank you for your support, there is some progress:
>> First i replaced usb-compat- with libusb-dependency in the formula.
>> sane-backends compiled, but still no usb-support.
>> Then i put »depends_on "pkg-config"« into the formula.
>> And here we go:
>> [sanei_usb] sanei_usb_init: initializing libusb-1.0
>> [sanei_usb] sanei_usb_scan_devices: marking existing devices
>> [sanei_usb] libusb_scan_devices: Looking for libusb-1.0 devices
>> [sanei_usb] libusb_scan_devices: device 0x04a9/0x221c at 038:002 is not
>> configured
>> [sanei_usb] libusb_scan_devices: found libusb-1.0 device (0x05ac/0x8215)
>> interface 0 at libusb:006:003
>> [sanei_usb] store_device: add dn 0 with libusb:006:003
>> Wow! This looked so good, until i realized that the device 0x04a9 "is
>> not configured" (and the other one is just the Bluetooth-USB-Controller).
>> So »scanimage -L« tells me, that there is still no scanner.
>> But this may be an unrelated issue, or isn't it?
>> (The scanner btw. is a CanoScan LiDE 60. Switching back to sane-backends
>> 1.0.25 shows this:
>> found USB scanner (vendor=0x04a9 [Canon], product=0x221c [CanoScan],
>> chip=GL842) at libusb:038:002).
>> Ah, here is the log:
>> https://gist.github.com/6875017d99847cd4bfa5613f61216306
>> Gruß,
>> Thomas.S
>> (aka schmo-fu)
>> Am 27.07.17 um 14:51 schrieb Yurii Kolesnykov:
>>> Hi, Olaf, Thomas!
>>> Having another round through the info in the various links you and Yurii
>>>> provided I noticed
>>>>  checking for pkg-config... no
>>>> Is homebrew using pkgconfig instead?  If so, I'd suggest adding
>>>> something like
>>>>  system "ln", "-s", "pkg-config", "/usr/bin/pkgconfig"
>>> No need to do this, in brew this may be addressed by adding `depends_on
>>> "pkg-config"`
>>> *before* running configure to sane-backends.rb.  Adjust /usr/bin as
>>>> necessary.  While at it, also drop the
>>>>  depends_on "libusb-compat"
>>>> or replace it with something like
>>>>  depends_on "libusb-1.0"
>>>> at least, do yourself a favour and build against libusb-1.0.
>>> Thomas, please try putting just `libusb` here, we have such formula:
>>> https://github.com/Homebrew/homebrew-core/blob/master/Formula/libusb.rb
>>> This formula Olaf?
>> -- 
>> sane-devel mailing list: sane-devel at lists.alioth.debian.org
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
>> Unsubscribe: Send mail with subject "unsubscribe your_password"
>>             to sane-devel-request at lists.alioth.debian.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20170727/9cb46a89/attachment-0001.sig>

More information about the sane-devel mailing list