[sane-devel] Canon PIXMA TS8050 compatibility - PIXMA TS8000 Series

Johannes S. johannes.w.seitz at gmail.com
Thu Jun 15 09:28:30 UTC 2017

Hi there,

I just got my new TS8050 and tried to configure SANE to scan from the
TS8050 over the network (the same way worked for my old PIXMA MX925).The
Scanner is listed as "Testers needed" on the SANE website, so here's my
experience report:

The scanner has a static IP set to, my sane configuration
contains the following entry:


When I run `scanimage -L` I get the following error message:

[bjnp] udp_command: ERROR - no data received (timeout = 1000)
> [bjnp] bjnp_init_device_structure: Cannot read mac address, skipping this
> scanner
> [bjnp] udp_command: ERROR - no data received (timeout = 1000)
> [bjnp] add_scanner: ERROR - Cannot read scanner make & model: bjnp://
> device `v4l:/dev/video0' is a Noname Integrated Camera virtual device

When I try and scan the device with nmap I get the following report:

~ sudo nmap -sU
> Starting Nmap 7.50 ( https://nmap.org ) at 2017-06-15 11:25 CEST
> Nmap scan report for
> Host is up (0.036s latency).
> Not shown: 993 closed ports
> PORT     STATE         SERVICE
> 68/udp   open|filtered dhcpc
> 161/udp  open          snmp
> 500/udp  open|filtered isakmp
> 1900/udp open|filtered upnp
> 1901/udp open|filtered fjicl-tep-a
> 5353/udp open          zeroconf
> 5355/udp open|filtered llmnr
> MAC Address: 84:BA:3B:83:58:44 (Canon)
> Nmap done: 1 IP address (1 host up) scanned in 3.48 seconds

Looks to me like the bjnp protocol is not supported by this model? Is there
any other test I can run to help?

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20170615/ac5f445e/attachment.html>

More information about the sane-devel mailing list