[sane-devel] Error scanning with Canon Lide 100

Robert A. Schmied uwppp at flash.net
Thu Aug 2 18:21:29 BST 2018

dnilabs e.U wrote:
> Hi! thank you for answering! comments below.
> Am 2018-08-01 um 21:00 schrieb Robert A. Schmied:
>  dnilabs e.U wrote: 
>  hi guys! im having trouble with my canon lide 100, it has this annoying inverted stripe in the middle: https://imgur.com/a/iEhfs2O, while simple-scan works like this, scanimage -L doesnt show the scanner, but sane-find-scanner shows: "found USB scanner (vendor=0x04a9 [Canon], product=0x1904 [CanoScan]) at libusb:003:004" 
>  dont really know what to do :( 
>  using arch linux 
>  sane-config --version 
>  1.0.27 
>  btw. the scanner works perfectly fine on my macbook 
>  aloha eu 
>  first i suspect 'the scanner works perfectly fine on my macbook' is 
>  because you were using commercial scanner software and not sane. 
>  i just meant, that it doesnt seem like a hardware malfunction.
>  second, due to the way sane works without an lide-100 i really cannot 
>  get too far into the detailed interactions between your scanner and the 
>  sane genesys backend (or frontend either), but based on my lide-200 and 
>  interactions with 1.0.27 sane here on a prehistoric sparc based unix box: 
>  i too experience the centered vertical stripe, in addition the overall 
>  scan seems to be too dark, meaning a white sheet isn't really 'white'. 
>   1) but scanimage -L should really find the scanner -- please provide all 
>      (any) output from the command (with the scanner plugged in of course). 
>      make sure file 'etc/sane.d/genesys.conf' is found by your sane installation 
>      (mine is at /opt/csw/) and the line usb 0x04a9 0x1904 is uncommented 2) might be really good if you could provide the complete command 
>      line you use with scanimage or the myriad config settings if using 
>      some gui frontend. 
>   3) find and remove $HOME/.sane/canon-lide-X00.cal where X is likely 1 
>      and then verify it is recreated when you do another scan. 
>   4) see some of my recent comments about the genesys backend and the 
>      lide200.  i've made a horrible and completely not understood hack 
>      that changes the default gamma and how the calibration is performed. 
>      it seems to help, but is a pita not to mention a pos hack. 
>  keep in touch, maybe we can collaborate and fix some of the issues with 
>  genesys backend and the lide scanners. 
>  regards 
>  ras 
>  wow just tried it again today now it shows: 
>  -> % scanimage -L          
>  device `genesys:libusb:003:005' is a Canon LiDE 100 flatbed scanner
>  but still the same error, also tried it with xsane, here the result, looks even worse to me. https://imgur.com/a/eqZJcWc
>  my try with: scanimage --format=tiff > test.tiff has the same stripe also...
> Beste Gr��e,
> Daniel Krahofer

aloha daniel

   %  scanimage --all-options
will list all options and arguments supported by the lide-100 genesys backend

based on the xscan image at the url you did a color scan.  it really doesn't
look too bad [for such an inexpensive scanner].  the problematic vertical strip
is still present and in my experience will always be present without my horrible
genesys backend hack.  it looks to me like you did delete the old calibration
file and sane regenerated a new one for this scan.  this calibration file will
be used for about 24 hours if the internals are suitable for the next scan you
make.  i'm not so sure all the code involved in this calibration processing
has been comprehensively tested, but that is my understanding of the code.

the color-fringing on right edge of the gameboy object is also something i see
with my lide-200.  i have basically reverted to --mode=gray and given up on
--mode=color unless it is really important for a color image.  plus my system
being bigendian or with a horrible usb-2 subsystem or ??? simply fails to do
the right thing with --depth=16.

don't know what --resolution you have set with xsane, you might try 
    --resolution 200
anything higher than that seems to take forever, and in --mode=color on my
lide200 some scanlines are duplicated instead of read from the scanner
(at least i think that is what is happening) causing the image to be
'stretched' in the length it is also incomplete the bottom part not being
scanned at all.

just to give us a basic view of scanner-sane performance try a scan of printed
text on white paper with command line(s) like the following:

    %  rm $HOME/.sane/canon-lide-*.cal
    %  scanimage --resolution 200 --depth=8 --mode=gray --format=pnm >/tmp/printed_text.pnm

note any of the output formats equally acceptable [ -format=pnm|tiff|png|jpeg ]
you can send me the image direct or post it.

daniel -- i will send to you directly 2 images of same printed text, one with
stock sane-genesys backend, the other with the ras-hack genesys backend.
i cannot predict if the ras-hack will help the lide-100, and i expect i've
hacked the backend only for an lide-200 and so will have to extend it for the
lide-100 model.



More information about the sane-devel mailing list