[sane-devel] Canon MX922 scan error

J. Paul Bissonnette jpaulb at eastlink.ca
Sun Feb 25 18:45:04 UTC 2018

On Sat, 24 Feb 2018 15:14:22 +0100
Louis Lagendijk <louis at fazant.net> wrote:

> On Fri, 2018-02-23 at 15:20 -0400, J. Paul Bissonnette wrote:
> > 
> > Sanner is discoverable and on the same net
> > 
> > I set the Firewall 	
> > BJNP	8612-8612	TCP	8612-8612
> > Problem even when firewall is disabled
> >   
> Ok, when the firewall is off and the problem still occurs, that can't
> be the poblem. In any case you will have to allow UDP as well. 
> The protocol uses both TCP and UDP.
> > Man sane-pixma claims the MX920 series is supported
> > output frpm avahi-discover
> > jpb at maple:~$ avahi-discover
> > Browsing domain 'local' on -1.-1 ...
> > 
> > '_canon-bjnp1._tcp' in domain 'local' on 2.0 ... Browsing for
> > services  
> Ok, bjnp is supported, good
> Can you please do the following (as root):
> Z%230
tcpdump host <ip-address of scanner>
> and then in a different window:
> scanimage -L
> and mail me the output of both commands?
> Some things you should try first:
> 1) Connect the scanner usinga USB cable. Does itwork?
> 2) Is the scanner connected over WIFI?
> If so and you have a recent sane version, you could try to define to
> define the scanner using a timeout value (e.g. at the start of the
> file specify
> bjnp-timeout=5000
> See the description in the /etc/sane.d/pixma.conf (or whatever path
> your distribution uses). The timeout parameter is supported since
> sane- backends 1.0.27.
> What OS/distribution are you using?
> /Kind regards, Louis

I checked the scanner with windows 7, the scanner is functional.

jpb at maple:~$ sudo tcpdump host
[sudo] password for jpb: 
tcpdump: verbose output suppressed, use -v or -vv for full protocol
decode listening on eno1, link-type EN10MB (Ethernet), capture size
262144 bytes 08:54:51.457427 IP >
UDP, length 32 08:54:51.457464 IP > UDP, length 32 08:54:51.522781 IP > UDP, length 16 08:54:51.524481 IP > UDP, length 32 08:54:51.524629
IP > UDP, length 16
08:54:51.526334 IP > UDP, length
117 08:54:51.571296 IP > UDP,
length 16 08:54:51.573604 IP >
UDP, length 32 08:54:56.821491 ARP, Request who-has tell, length 28 08:54:56.822500 ARP, Reply is-at
00:bb:c1:22:e6:97 (oui Unknown), length 46

jpb at maple:~$  scanimage -L
device `pixma:MX920_192.168.0.108' is a CANON Canon PIXMA MX920 Series
multi-function peripheral

1) Connect the scanner using a USB cable. Does it work? No
2) Is the scanner connected over WIFI? Yes

Canon firmware is V 3.031

 uname -a
Linux maple 4.15.5-041505-lowlatency #201802221031 SMP PREEMPT Thu Feb
 22 15:35:41 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 xsane -v
xsane-0.999 (c) 1998-2013 Oliver Rauch
  E-mail: Oliver.Rauch at xsane.org
  package xsane-0.999
  compiled with GTK-2.24.29
  with color management function
  with GIMP support, compiled with GIMP-2.8.16
  XSane output formats: jpeg, pdf(compr.), png, pnm, ps(compr.), tiff,
 txt jpb at maple:~$ 

I works sort of now 
by setting bjnp-timeout=5000 
timeout at 5000 seemed too slow of a response time

Save scan
set bjnp-timeout=1000

1st click on scan error
[bjnp] bjnp_open_tcp: ERROR - Can not connect to scanner: Connection
refused 2nd click no error
save number is advanced from 001.jpeg to 002.jpeg
1st click on scan error
[bjnp] bjnp_open_tcp: ERROR - Can not connect to scanner: Connection
refused 2nd click no error
the save number is advanced

I want to thank you for the help
too bad Canon was not a bit more Linux friendly.
This is the first canon scanner I have owned all the others for the
last 20 years were either HP or Epson. They just simply work.
anyways thanks again the scanner limps along now which was more that it
has in a long time.

Has something been changed with the drivers lately this scaner worked
fair when I bought it then it quit. Ubuntu form made a few suggestions,
it worked for a while then recently quit again.
 I have been using the drivers from the

More information about the sane-devel mailing list