[sane-devel] Question on Parallel port devices

Mauricio Hunt mauricio_hunt at hotmail.com
Sat Jan 12 20:40:42 GMT 2019


I have a question about the use of a parallel port scanner (Epson Actionscanner II). In the past I did this and worked just fin:

Remove comment for the Epson back-end here


Modify this file to add port in the EPSON entry, in my old PC, the port was 0x378


# epson.conf
# here are some examples for how to configure the EPSON backend
# SCSI scanner:
scsi EPSON
# for the GT-6500:
scsi "EPSON SC"
# Parallel port scanner:
#pio 0x278
pio 0x378
#pio 0x3BC

I bought a new PC and got rid of the old one, the new one doesn't has a parallel port so I got a PCI card with the parallel port.

I use Open Suse and it recognizes the parallel port

ls -l /dev/lp*
crw-rw---- 1 root lp 6, 0 Jan 12 14:21 /dev/lp0
crw-rw---- 1 root lp 6, 1 Jan 12 14:21 /dev/lp1
crw-rw---- 1 root lp 6, 2 Jan 12 14:21 /dev/lp2
crw-rw---- 1 root lp 6, 3 Jan 12 14:21 /dev/lp3

dmesg | grep parport0
[    7.130079] parport0: PC-style at 0xd020, irq 26 [PCSPP]

so the parallel port is there and 'active' at 0xd020, using that IO address in the procedure above gives no results, the scan front-end (scanlite, xsane, etc..) or by shell command returns that there are no devices found.

the frontend is run under 'root'.

I had this since 3 years ago, I wanted to try again, didn't find much new information, so I?m posting here in case any has a better idea or something I haven't tried.

Any help is welcome.

Thank you

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20190112/dbbf3a96/attachment.html>

More information about the sane-devel mailing list