[sane-devel] Plustek M12 firmware corruption? (Re: Plustek M12 passes "scanimage -T" but doesn't work)

r. a. schmied uwppp at flash.net
Sun Jun 23 21:28:35 BST 2019

Perry Hutchison wrote:
> A couple of weeks ago I wrote:
>>I recently picked up a NeatReceipts Scanalyzer, which SANE recognizes
>>as a Plustek OpticSlim M12, at a thrift store.
>>  # scanimage -L
>>  device `gt68xx:libusb:/dev/usb0:/dev/ugen0' is a Plustek OpticSlim M12 flatbed scanner
>>  # scanimage -p -v -d gt68xx:libusb:/dev/usb0:/dev/ugen0 > scantest.pnm
>>  scanimage: scanning image of size 2575x3531 pixels at 8 bits/pixel
>>  scanimage: acquiring gray frame
>>  scanimage: read 9092325 bytes in total
>>  # scanimage -V
>>  scanimage (sane-backends) 1.0.17; backend version 1.0.17
> Someone suggested, off-list, trying a newer version of SANE.
> I've now been able to try 1.0.27, on a different machine running a
> different OS (Ubuntu 18.04) with a different USB cable, and got the
> same result:  the scanner's motor does not run, and it generates an
> all-gray image file.
> Using a different machine and cable seems to exclude most possible
> hardware-related issues other than the scanner itself, but I suppose
> it's possible that the firmware file I'm using could be corrupted.
> Does anyone have a Plustek M12 working, and if so could you post a
> hash (MD5, SHA1, whatever) of the cism216.fw file?

maybe posting yours in a couple of hash flavors would give possible
respondents a clue if theirs differs and might be helpful.


aloha perry, interested saners

way back on 06/06/19 16:26 you posted that the command line
   # scanimage -p -v ...
did list 100s of 'Progress:' lines

so the backend thought the scanner was sending image data.

scanimage -L reported the device as a "Plustek OpticSlim M12 flatbed scanner"
i don't recall seeing a 'NeatReceipts Scanalyzer' in a flatbed format.

can you confirm it is NOT a flatbed?
can you expand a bit on the scanners two buttons?

    # scanimage -p -v -d gt68xx:libusb:/dev/usb0:/dev/ugen0 > scantest.pnm
    scanimage: scanning image of size 2575x3531 pixels at 8 bits/pixel
    scanimage: acquiring gray frame
implies the image file is gonna be gray-scale

using 1.0.27 scanimage the output file will be whatever the backend
defaults are irrespective of the .pnm extension.

can you confirm the image file looks to be a pnm file?

have you tried with --format tiff, writing to scantest.tif>

don't know if that will tell us anything more, but who knows.

what does 
   # sane-find-scanner -v -v
you can include -d 'gt68xx:libusb...' but don't, so it will list all
usb devices that it finds (at least that is what is happening here).

so have you had any luck finding a (dis)assembly diagram for scanner
so you can lift its skirts without breaking things?

are you equipped with o'scope or dmm?

first i'd check how you apply power to scanner:

you don't mention this so i presume it is not present
  if the scanner has a separate power input port other than usb are you
  applying power that way?  if so have you checked that power source is
  actually providing adequate power (voltage + current) when the scanner
  is supposed to scan?  way way way way way back when i had dial-up service
  modem was powered with a wall-wart.  modem checked out fine; passed all
  tests etc, until i did something that put data on the phone line
  -- turned out the wall-wart was working about 25% capacity, just
  enough to power the serial interface and modem processor, but not
  enough to drive the phone line interface.

this is still possible, though unlikely, given results on two different machines
  if you are not using or don't have a separate power input port on the
  scanner are you sure your usb port is actually providing adequate power
  (voltage + current) when the scanner is supposed to scan?  when i added
  an officedepot ativa hub without external power applied to the hub and
  plugged my lide200 into hub my system claimed port power on the hub usb
  connection was excessive and shut that port down.

after confirming there is adequate power to the scanner you're gonnna
need your anti-static hat and gloves and pop the cover(s) off the

make sure there are no obvious jams in the motor to paper drive train.

make sure any optical sensors are clear of dust and lint.

make sure the motor is actually NOT running when a scan is initiated.
way way way back when i put a new (only the second) toner cart in my
hp lj4mp it constantly resulted in 'paper jam'.  turned out the motor
drive gear was cracked and simply slipped on the motor drive spindle,
as the motor ran with a significant load.  reinstalling the old but
out-of-toner cart and the thing worked fine, producing a fine, but
out-of-toner characteristic print.  tried at least three different
new toner carts (hp and clone without success).  finally gave up
until i found a note about this generic hp lj4mp problem.  replaced
the gear and all is good again, yet another working [again] obsolete
bit in my collection of [still working] obsolete computer stuff.

you need to check for this sort of problem on the scanner.

with all that mechanical stuff out of the way you will need o'scope
[ best ] or volt meter [ ok but limiting ].

for a simple 2 wire motor (eg not a stepper)

   make sure power is getting to the motor terminals when scan is going.

   trace the circuitry back as far into the circuitry as possible.

   you might find a blow fuse, power fet or xsister that is easily
   (relative: you will have to melt and remelt solder).

   if circuitry looks intact, no obvious burnt or wrinkled black
   ic devices and the motor is not getting power the odds are
   good there is just a bit or four that needs to be toggled.

   but if motor is getting power, and you confirm it isn't running
   then motor is likely bad.

for a stepper motor

   well now things get really complicated -- o'scope (or freq counter)
   may well be needed to diagnose.

   make sure motor is getting adequate power, i expect there will be
   one of 5 or 7 leads that provides power, which the other leads
   will switch on/off sequentially.

if you have managed to locate an electrical schematic for this scanner
or scanner class and want to share please do so, it might help focus
the troubleshooting.  closeup photos of the inners might also be helpful ...

terry: just trying to help, you've probably done most, if not all
of this yourself already.

best of luck


ps -- at some point you might have to give it up and pony up to
50 usd for a different scanner.  i'd stay away from hand scanners
but a visoneer roadwarrior x3 on amazon for $ 43 is a reasonable
candidate [provided sane-1.0.27 support unchecked].  ebay
lists lots of canoscan lide models below $ 50 pricepoint -- ras

More information about the sane-devel mailing list