[sane-devel] libusb not available

Pim van Tend pimvantend at yahoo.com
Fri Mar 22 14:12:07 GMT 2019

When I run sudo sane-findscanner -vv from the ubuntu-sane-package, I get:
checking /dev/usbscanner15... failed to open (Invalid argument)
found USB scanner (vendor=0x04a9 [Canon], product=0x2225 [CanoScan]) at libusb:001:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.
When I run the same with a self-maked sane, I get:
checking /dev/usbscanner15... failed to open (Invalid argument)
libusb not available
  # No USB scanners found. If you expected something different, make sure that
In fact there are many libusb-packages installed:
libusb-0.1-4/bionic,now 2:0.1.12-31 amd64 [installed]
libusb-1.0-0/bionic,now 2:1.0.21-2 amd64 [installed]
libusb-1.0-0-dev/bionic,now 2:1.0.21-2 amd64 [installed]
libusb-1.0-doc/bionic,bionic,now 2:1.0.21-2 all [installed]
libusb-dev/bionic,now 2:0.1.12-31 amd64 [installed]
libusbmuxd4/bionic,now 1.1.0~git20171206.c724e70f-0.1 amd64 [installed]
python-libusb1/bionic,bionic,now 1.6.3-1 all [installed]

With libusb-dev removed, you do not get this far. Keeping or removing
libusb-1.0-0-dev makes no difference.

Part of the output op ./configure:
checking for SYSTEMD... no
checking for USB... no
checking for USB... no
checking usb.h usability... yes
checking usb.h presence... yes
checking for usb.h... yes
checking for usb_interrupt_read in -lusb... yes
checking lusb0_usb.h usability... no
checking lusb0_usb.h presence... no
checking for lusb0_usb.h... no
checking IOKit/scsi/SCSITaskLib.h usability... no

output from the makeing of sane-find-scanner:
for subdir in hal hotplug hotplug-ng udev; do \
  /bin/mkdir -p $subdir || exit 1; \
make  all-am
make[1]: Entering directory '/home/zeeman/backends/tools'
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Wextra -pedantic -g -O2   -o sane-find-scanner sane-find-scanner.o check-usb-chip.o ../sanei/libsanei.la ../lib/liblib.la -lusb -lieee1284  ../backend/sane_strstatus.lo 
libtool: link: gcc -Wall -Wextra -pedantic -g -O2 -o sane-find-scanner sane-find-scanner.o check-usb-chip.o ../backend/.libs/sane_strstatus.o  ../sanei/.libs/libsanei.a ../lib/.libs/liblib.a -lusb -lieee1284
make[1]: Leaving directory '/home/zeeman/backends/tools'

Is the binary libusb somehow not detected in the configure-process?
Or something else?


More information about the sane-devel mailing list