[sane-devel] your-firmwarefile.bin

Jono bitrat at fastmail.fm
Sat Aug 8 00:44:35 BST 2020

Hi Torfinn, Olaf and Oliver,

thanks very much for all the help.

I have to say I was a bit shocked when I realised what I was in for to get my old scanner going!  I've been wondering if I should just get an old desktop and run XP on it...

Also, Torfinn, as you noted..
> your scanner is also listed as not supported here: http://sane-project.org/sane-mfgs.html
TBH I did check that table, but I seized on the previous line, which is for the "Perfection 2480" (which is supported) and not the "Perfection 2480 PHOTO" (which isn't).  What's the difference I wonder...

Anyway, my effort to find the driver at http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX ended with a 404
"The requested URL /dsc/f/01/00/01/58/30/7b7ace27e78fc18e081f8300ebc1af394f88812d/iscan-2.10.0-1.i386.rpm was not found on this server."

On the assumption that I can get the same firmware from a windows driver, I got one from here:
$ wget https://ftp.epson.com/drivers/epson12204.exe
$ unzip -d tmp  epson12204.exe
$ cabextract -F *.bin tmp/ModUsd.cab
$ ll
total 20652
drwxr-xr-x 3 bitrat bitrat     4096 Aug  8 10:42 ./
drwxr-xr-x 4 bitrat bitrat     4096 Aug  8 10:11 ../
-rw-r--r-- 1 bitrat bitrat 21003040 Dec  4  2015 epson12204.exe
-rw-r--r-- 1 bitrat bitrat    64000 Nov  3  2004 esfw30.bin
-rw-r--r-- 1 bitrat bitrat    64000 Oct 28  2004 Esfw41.bin
drwxr-xr-x 3 bitrat bitrat     4096 Aug  8 10:42 tmp/

I modified /usr/local/etc/sane.d/snapscan.conf to point at the firmware...

firmware /home/bitrat/opt/scanner/sane/bitrat/Esfw41.bin

Then I tried running scanimage, without much success..
After power cycling the scanner...

$ scanimage --help
scanimage: open of device snapscan:libusb:003:016 failed: Error during device I/O
Type ``scanimage --help -d DEVICE'' to get list of all options for DEVICE.

List of available devices:

[sometimes 'scanimage --help' causes an an error (flashing red light), so a power cycle required here..]
[status light yellow..]

$ scanimage -d snapscan:libusb:003:019
Output format is not set, using pnm as a default.
scanimage: output is not a file, exiting

[with the status light flashing red..]

$ scanimage
Output format is not set, using pnm as a default.
scanimage: open of device snapscan:libusb:003:021 failed: Error during device I/O

After a power cycle, the scanimage command causes the scanner motor to run briefly, and the status light to flash bright yellow twice, then the status light goes from dim yellow to fast flashing red.  Needs another power cycle to reset.  Disconnecting and reconnecting from the USB doesn't reset the scanner.

I also tried using esfw30.bin, with similar results.

Sorry if I'm expecting too much here, but I really don't have the time to spend on this.  It would be great if anyone has any further suggestions, otherwise, I think I'll try a Windows setup.

Thanks again everybody!  Very much appreciated!
  bitrat at fastmail.fm

On Sat, Aug 8, 2020, at 7:15 AM, Oliver Schwartz wrote:
> Hi all,
> > Am 07.08.2020 um 12:27 schrieb Olaf Meeuwissen <paddy-hack at member.fsf.org>:
> > 
> > Hi Torfinn, Jono,
> > 
> > Torfinn Ingolfsen writes:
> > 
> >> On Fri, Aug 7, 2020 at 2:31 AM Jono <bitrat at fastmail.fm> wrote:
> >>> 
> >>> My scanner is:
> >>> 
> >>> ______________________________
> >>> $ lsusb
> >>> .
> >>> .
> >>> Bus 003 Device 013: ID 04b8:0121 Seiko Epson Corp. GT-F500/GT-F550 [Perfection 2480/2580 PHOTO]
> >>> ==================================
> >> 
> >> First of all: it does seem wrong that SANE tries to use the snapscan
> >> backend (see sane-snapscan(5) man page) with your scanner. Since it is
> >> ...
> > 
> > Sorry to tell you wrong but there are several EPSON scanners that speak
> > a protocol different from EPSON's ESC/I protocol.  The latter is
> > supported by the epson, epson2 and epsonds backends and the epkowa and
> > utsushi external backends.  Some of those "odd-ball" scanners are
> > supported by the snapscan backend.
> This one (Perfection 2480 / 2580) definitely is supported by the 
> snapscan backend.
> >> The firmware is not distributed by SANE for obvious reasons. If you
> >> have such a scanner, you will have to find and extract the firmware
> >> file from the (Windows) driver / install yourself. (I had a SnapScan
> >> scanner once, there was a SnapScan_XXX.bin file in a directory of the
> >> windows install; this was the firmware so I just copied it and
> >> configured SANE to use it)
> > 
> > You should also be able to find it in the RPMs that you can download via
> > 
> >  http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
> > 
> > The firmware file does not depend on the gcc version or CPU type.  You
> > are looking for a file matching esfwXX.bin, IIRC, where the XX is a two
> > digit hexadecimal value.
> According to my notes, the firmware file for this scanner is named esfw41.bin.
> Kind regards,
> Oliver

More information about the sane-devel mailing list