[sane-devel] Problem with new Canon iSensys MF746Cx

Andrea Croci andrea.croci at gmx.de
Tue Sep 15 16:35:51 BST 2020

Hello Loius,

Thank you for your reply. Avahi sees the scanner at Port 80. On ubuntu
20.04 I do have a newer version of SANE, with which the scanner works
with the escl backend. That's fine for now. The only problem is that the
options for the scanner are reduced to a very minimum (no brightness
control, for instance). On 18.04 (Desktop) I solved the problem by
installing the sane-airscan backend, which however has the same minimal
options as escl.

I would really love to see the day where Linux has a scanning program as
good as some of the proprietary programs for Windows: one that has all
the scanning options in one program (possibly selectable from a menu)
and ESPECIALLY that produces pdf files in the kB range instead of the
MB, like xsane does now (or did the last time I used it, about 10 years


On 14.09.20 17:04, Louis Lagendijk wrote:
> On Tue, 2020-09-08 at 06:20 +0200, Andrea Croci wrote:
>> Hello,
>> I have just installed a new Canon iSensys MF746Cx on Ubuntu 18.04 and
>> I
>> can't get it to scan. It' connected over the network. I haven't found
>> any driver or software for scanning on Canon's Website, so I was
>> hoping
>> I could do it with sane. I have read on the list of supported devices
>> that the MF741/743 are fully supported by the pixma backend.
>> So I activated the pixma backend in /etc/sane.d/dll.conf by
>> uncommenting
>> it and edited the /etc/sane.d/pixma.conf file by adding
>> "bjnp://address.here:8612". Scanimage -L gives me this message:
>> [bjnp] udp_command: ERROR - no data received (timeout = 5000)
>> [bjnp] bjnp_init_device_structure: Cannot read mac address, skipping
>> this scanner
>> [bjnp] udp_command: ERROR - no data received (timeout = 5000)
>> [bjnp] add_scanner: ERROR - Cannot read scanner make & model:
>> bjnp://
>> Because CUPS adds the printer with the ipp protocol on port 631, I
>> tried
>> with other things as well (port 631, ipp protocol, net) but I always
>> get
>> the same error messages.
>> My Epson WF7620 works great with both the "epson2" and the "epkowa"
>> backends.
>> Any help would be appreciated. Thank you.
> defining the scanner in pixma.conf is normally not required. Can you
> please check the output of the _scanner._tcp entry from avahi-discover
> and check the port number mentioned there. If that is 8612 it could
> work with the pixma backend.
> Newer Canon scanners apparently no longer support bjnp, so the pixma
> backend only works over USB.(_scanner._tcp refers to port 80 or maybe
> 443) If you have a newer sane version (preferably 1.0.31)  you can
> probably use the escl backend.
> /Louis

More information about the sane-devel mailing list