[sane-devel] I'd like to scan via Canon iSensys MF746Cx & can test things for you

Swen Dietrich swen.dietrich at mailbox.org
Fri Mar 26 20:11:15 GMT 2021

Hi all,

> That device has some problems as a printer with the supplied driver
> under Linux

tbh for me the device worked wonderfully out of the box.

Printing works fine and all the settings are also auto detected and work
as far as I can tell (e. g. duplex printing, scaling, colour, ....)
Both flatbed and adf scanning worked until recently.

It was all fine and dandy until some idiot (me) uninstalled the wrong
debian package and now scannign no longer works.
Simple-scan said it can't connect to the device.
scanimage reports this:

> > sudo scanimage -L           
> device `escl:' is a ESCL CNMF745C/746C (USB) flatbed scanner
> > sudo scanimage > /tmp/output
> Output format is not set, using pnm as a default.
> scanimage: open of device escl: failed: Out of memory

This isn't a support forum but when someone can tell me which debian
package I need to get this working again this would be truly wonderful.

I'm running

> Linux hostname 5.10.0-3-amd64 #1 SMP Debian 5.10.13-1 (2021-02-06) x86_64 GNU/Linux

Greetings from germany
Swen Dietrich

On 26/03/2021 17.59, Andrea Croci wrote:
> Hello,
> I have this same device and initially had some problems with it. I was
> in contact with Alexander and did some tests for him (not full though, I
> got sidetracked after a while).
> The device works with both airscan and eSCL (maybe they are even the
> same thing, although they are listed as two devices by scanimage -L).
> The only problem is that they always get like a different address or
> something and they are not always addressed properly by scanimage. But
> it's not a big deal, one only has to play with the names a little bit
> and it will work.
> I now use gscan2pdf because it saves me time with the conversion to pdf
> files, especially if I only want to save a selection of the pages and
> not all of them. There I have the same problem: when I open gscan2pdf
> after not having used it for a while, it doesn't find the scanner. I
> have to let it scan for devices again and then it will find it and work
> great.
> That device has some problems as a printer with the supplied driver
> under Linux (Canon is terrible at customer service here), but that's a
> story for the CUPS mailing-list. Swen, if you have problems setting it
> up as a printer, you may mail me and I'll tell you how I got it (after
> days of trying).
> Regards.
> On 26.03.21 17:40, Ralph Little wrote:
>> Hi,
>> On 2021-03-26 8:24 a.m., Swen Dietrich via sane-devel wrote:
>>> Hello SANE Developers,
>>> the list of backends said "Testers needed!" for my printer.
>>> I'm owner of a Canon iSensys MF746Cx.
>>> How can I help with driver development for this printer?
>> Usually, if the appropriate backend picks it up, testing merely involves
>> trying all of the available options.
>> Said support might be wrong (flatbed scan area for example) so we would
>> correct those things.
>>> The device was not connected to the internet yet and thus the
>>> factory-drivers are still installed on the printer.
>>>> Bus 003 Device 048: ID 04a9:27fa Canon, Inc. MF745C/746C
>>>> Device Descriptor:
>>>>    bLength                18
>>>>    bDescriptorType         1
>>>>    bcdUSB               2.10
>>>>    bDeviceClass            0
>>>>    bDeviceSubClass         0
>>>>    bDeviceProtocol         0
>>>>    bMaxPacketSize0        64
>>>>    idVendor           0x04a9 Canon, Inc.
>>>>    idProduct          0x27fa
>>>>    bcdDevice            0.00
>>>>    iManufacturer           1 Canon
>>>>    iProduct                2 MF745C/746C
>>>>    iSerial                 3 <snip!>
>>>>    bNumConfigurations      1
>> This device is not listed at all on our "Supported Devices" page (based
>> on the supplied USB ids) so at this point I guess we don't know what
>> protocols are supported.
>> I see from a datasheet that this is a fairly new device, perhaps
>> released in 2019. Older Canon devices used MFNP and BJNP protocols.
>> However, IIRC, modern Canon devices are not and are instead using eSCL.
>> Cheers,
>> Ralph

More information about the sane-devel mailing list