[DSE-Dev] star: fails on setting xattr on symlink

Václav Ovsík vaclav.ovsik at i.cz
Fri Dec 7 13:29:15 UTC 2007

I'm playing with selinux. Star is considered only tool on Debian (AFAIK)
capable of backuping/copying selinux contexts (stored as xattrs in
filesystems). When I tried to copy filesystem with star found, that star
is not capable to handle xattr of symbolic links (it does dereference).
This is setxattr/lsetxattr/getxattr/lgetxattr problem.
The problem is solved in newer upstream versions, at least version
1.5a75 from CentOS is ok.
Please upgrade to more recent version of star.
Best Regards.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.18-5-xen-686 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=cs_CZ.ISO-8859-2 (charmap=ISO-8859-2)
Shell: /bin/sh linked to /bin/bash

Versions of packages star depends on:
ii  libacl1                       2.2.45-1   Access control list shared library
ii  libattr1                      1:2.4.39-1 Extended attribute shared library
ii  libc6                         2.7-3      GNU C Library: Shared libraries

star recommends no packages.

-- no debconf information

More information about the SELinux-devel mailing list