[Freedombox-discuss] All images for FreedomBox 0.5 built and uploaded

Markus Sabadello markus at projectdanube.org
Tue Aug 11 12:35:09 UTC 2015

On 08/10/2015 06:58 PM, Sunil Mohan wrote:
> On 08/09/2015 01:04 AM, Markus Sabadello wrote:
> [...]
>> That was yesterday. Today I'm trying again and during first-run I get
>> endless log lines like this on the console..
>> [    5.973081] systemd[1]: Time has been changed
>> [    5.977827] systemd[1]: Time has been changed
>> [    5.982432] systemd[1]: Time has been changed
>> The boot process then never seems to complete, and some other errors
>> show up as well.
>> I guess I somehow messed up one of my CubieTrucks.
>> When I try the same image on a different CubieTruck, it works again
>> without problems.
> It looks like it is something to be worried about.  Other people seem to
> have faced the issue[1].  They say that when this happens, the system is
> quite slow (perhaps the cause).
I was able to fix this by restoring my CubieTruck's bootloader (NAND) to
In other words, this probably has nothing to do with the FreedomBox image.
But I'm not sure how my NAND got corrupted in the first place.
>> Another thing I noticed is that the firmware-atheros package was missing
>> for the USB AR9271 adapter.
> I just created a bug (#795103) in freedombox-setup package for it.
>> I installed it manually via SSH, and got a new interface called
>> "wlx485d602a76ad".
> This naming scheme is systemd's new predictable naming scheme which we
> have started to take advantage of.
> [...]
>> Internet access via that AP works (I get IP, but DNS
>> resolution of "freedombox" fails.
> This was reported to work.  Looks like a regression.  I have created a
> bug against freedombox-setup for this.
Yes, just to verify, I tried again today with a different CubieTruck and
fresh image and different client device, but it still doesn't work.
I also remember this worked at some point, but right now I don't
understand well enough how NetworkManager, dnsmasq, and nsswitch play
together exactly..
>> The Tor transparent proxy also doesn't work on that interface (is it
>> supposed to?).
> We have not implemented Tor transparent proxy.  Tor SOCKS proxy has a
> small bug.  Some discussion in bug #794845.
>> Sometimes when trying to install applications, I get this error in Plinth:
>> Error installing packages: E: http://http.debian.net sid/main armhf
>> Packages is not (yet) available ()
> Could this be an issue with a bad/slow mirror?
Yes probably. I'm using httpredir.debian.org now and it works fine.
> [...]
>> I'll keep testing more over the next few days to try everything on the
>> QualityAssurance page.
> Since our focus is now polish, please don't hesitate to report any minor
> annoyances and UI issues.
> Links:
> 1) http://archlinuxarm.org/forum/viewtopic.php?f=33&t=8912

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20150811/50e5b37b/attachment.sig>

More information about the Freedombox-discuss mailing list