[Freedombox-discuss] Need help with getting start

Jack Wilborn jkwilborn at gmail.com
Thu Nov 26 09:54:03 UTC 2015

I assume you can at least log in?  If so, using 'ifconfig' will show you
all available connections, from the Freedombox side.  Although I've
installed the latest Debian software, I have NOT added the 'Freedombox'
configuration to mine yet. Although, I use the Dreamplug for my system, I'm
still dealing with HDD drives for it and the output here is from my Ubuntu
flavor of Debian.  Hopefully I've assisted.?...  And I'm not to technically
out of it.

There are at least a number of items that you can check.

1.) use 'ifconfig' or any similar piece of software to locate ip address.
2.) 'ifconfig' will also show you the netmask, although usually not your
kind of problem.
3.) 'cat /etc/resolv.conf' and see what's in it.
4.) I don't know if you have tried to 'ping' your router as you should be
(hardware wise) connected.
    My router is on as an example and is my default 'gateway'
to the Internet.
5.) The last is your ip routing.  I have to look it up with 'man ip' from a
terminal window as I've only found it a couple of times to be the problem.
So go to here and use Google.com as a reference for many of your
questions.  And the IRC #Freedombox, to chat about problems, on-line.

here is my resolv.conf:


jack at Kilo:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by

These are added automatically, but sometimes I've found them with only the
localhost defined in them. This file is overwritten on boot so these need
to be checked.  Maybe someone knows off hand where to put these, as I can'
remember except something /etc/resovconf directory. The last three are put
in by me.  These are the DNS servers that are defined and their search
order.  Your network may be missing this and therefore cannot resolve
things like 'www.google.com'.  One way to see what's happening is to use,
if available, 'dig' or 'nslookup' to see what returned.
On my lan, I have a local DNS server, the is my home DNS
server.  Here is output from 'dig'


jack at Kilo:/$ dig cheetah.kilo.kat
; <<>> DiG 9.9.5-3ubuntu0.4-Ubuntu <<>> cheetah.kilo.kat
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42924
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;cheetah.kilo.kat.        IN    A

cheetah.kilo.kat.    604800    IN    A

kilo.kat.        604800    IN    NS    cheetah.kilo.kat.

;; Query time: 0 msec
;; WHEN: Thu Nov 26 02:32:09 MST 2015
;; MSG SIZE  rcvd: 75

jack at Kilo:/$


Quickly, the line with the answer showing query, status ("NOERROR"), and
the answer (1) and authority (also 1), both answer and authority came from
my DNS server.  You can also try it on anything that needs 'resolving' so
to speak.


Hope this helps.  At least it gives something to try...


On Wed, Nov 25, 2015 at 12:22 PM, ndcd <ndcdhimdsa at gmx.de> wrote:

> Thanks for the feedback. Now I have the IP address, but still no
> connection to the freedombox.
> I started Iceweasel without add-ins to make sure any of them does not
> interfere.
> Going to the IP-Address gives a
> "Unable to connect
> Iceweasel can't establish a connection to the server at <my-IP-Address>.
>     The site could be temporarily unavailable or too busy. Try again in a
> few moments.
>     If you are unable to load any pages, check your computer's network
> connection.
>     If your computer or network is protected by a firewall or proxy, make
> sure that Iceweasel is permitted to access the Web."
> Maybe this gives a clue:
> $ nmap -p 80 --open -sV --system-dns
> Starting Nmap 6.47 ( http://nmap.org ) at 2015-11-25 18:52 CET
> Nmap scan report for speedport.ip (<my-IP-Address>)
> Host is up (0.0020s latency).
> 80/tcp open  http    Apache httpd
> Service detection performed. Please report any incorrect results at
> http://nmap.org/submit/ .
> Nmap done: 256 IP addresses (2 hosts up) scanned in 8.69 seconds
> So it finds something, is it just my router it finds?
> Interestingly, as sudo it says "3 hosts up".
> My configuration is in a star, i.e. the freedombox (sid) is connected via
> LAN to the router and the other PC (Jessie) via WLAN to that router.
> Could it be my router is blocking something?
> How can I detect, if the necessary services are running on the freedombox?
> EDIT: I just found out I can do an SSH to the freedombox:
> $ ssh fbx@<IPADDRESS> <fbx at>
> The authenticity of host '<IPADDRESS> <fbx at> (<IPADDRESS>
> <fbx at>)' can't be established.
> ECDSA key fingerprint is <hex-code>.
> Are you sure you want to continue connecting (yes/no)? y
> Please type 'yes' or 'no': yes
> Warning: Permanently added '<IPADDRESS> <fbx at>' (ECDSA) to
> the list of known hosts.
> And then I'm in.
> But how do I get to Plinth? Is this Iceweasel blocking something?
> Thanks again
>    Dietmar
> PS: sorry Sunil for sending to your mail address instead of to the list
> Am Dienstag, den 24.11.2015, 08:01 +0530 schrieb Sunil Mohan Adapa:
> On 11/24/2015 12:32 AM, ndcd wrote:> I want to give freedom box a trial. For this I am using an old laptop> with ethernet and WLAN connection and installed first sid then> freedombox according to the manual. setup was run of course.> Now, according to the "Quick Start" I should be able to connect (from a> 2nd laptop in the same local network) to the new freedombox.> http://freedombox.local/ gives "server not found"> and> nmap -p 80 --open -sV> Starting Nmap 6.47 ( http://nmap.org ) at 2015-11-23 19:55 CET> Nmap done: 256 IP addresses (0 hosts up) scanned in 104.30 seconds>> Internet connection is active as I can do an apt-get update.> What did I miss?>
> This step is merely to find out the IP address the FreedomBox machine.
> The documentation is wrong is assuming that it will be in the
> range always.  It could be any of the other ranges such as
>  In your case, it is certainly not
> If you are logged into FreedomBox machine, you can find out the IP
> address directly by typing 'ip addr list'.  Then connect to http://<ip
> address>/.
> Further more, I hope you have followed the instructions inhttps://wiki.debian.org/FreedomBox/Hardware/Debian .  Pay particular
> attention to the troubleshooting item 2.
> _______________________________________________
> Freedombox-discuss mailing list
> Freedombox-discuss at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20151126/641f4aae/attachment.html>

More information about the Freedombox-discuss mailing list