[Freedombox-discuss] FreedomBox doesn't appear on my network after installation

franken.tunui at gmail.com franken.tunui at gmail.com
Mon Nov 12 19:07:38 GMT 2018

Ok thanks, seems easier anyway so will do! What do I need the serial USB for? If I flash an SD card then I do everything from there? ------ Message d'origine------De: Joseph NuthalapatiDate: lun., 12 nov. 2018 06:34À: franken.tunui at gmail.com;Cc: Adrian Gropper;freedombox-discuss at alioth-lists.debian.net;Sébastien Barthélémy;Objet :Re: [Freedombox-discuss] FreedomBox doesn't appear on my network after installationTunui,Since you mentioned that your board has a 4 GB eMMC, I'drecommend installing FreedomBox to the SD card instead since theoperating system itself might take up most of the 4 GB diskspace. FreedomBox applications are currently configured to useinternal storage only, though you might be able to change this ona per application basis. It is better to use the 16 GB microSDcard as your primary installation location and ignore the eMMCstorage for now. microSD will be slower than eMMC though."franken.tunui at gmail.com"  wrote:> Thank you, I'll probably give it a try in a couple days, if I> get to understand everything...Do I just plug in a keyboard and> screen to the Lime2? And last question, if I install to eMMC> will I be able to uninstall everything from the eMMC later when> a valid FreedomBox image is available? Thank you for your help!> ------ Message d'origine------De: Sébastien BarthélémyDate:> lun., 12 nov. 2018 00:19À: agropper at healthurl.com;Cc: Tunui> Franken;freedombox-discuss at alioth-lists.debian.net;Objet :Re:> [Freedombox-discuss] FreedomBox doesn't appear on my network> after installationOn Sun, Nov 11, 2018 at 12:58 PM Sébastien> Barthélémy  wrote:I think you can install> an armbian recommended by Olimex, and "sudo apt install> freedombox" from there.I have not tried yet, but will probably> do.I just gave it a try, it worked (as far as I tested).Here a> my notes (for my future self, don't follow them blindly). I> used an USB-serial cable because I have one, but using ethernet>   should also work.1/ install armbian following instructions from https://docs.armbian.com/User-Guide_Getting-Started/*  download Armbian_5.65_Lime2_Debian_stretch_next_4.14.78.7z from  https://dl.armbian.com/lime2/Debian_stretch_next.7z* uncompress and copy it to SD card.* plug the USB-Serial adapter, run kermit* power the lime2, watch console logs while it boots* login (root/1234), and follow instructions. I created a user "seb", maybe I should have ctrl-c instead, because freedombox will also want to create a user.* plug the ethernet cable, watch the board get an ip using journaltlf -kf* update the OS:    apt update && apt upgrade* install to eMMC (use ext4 filesystem)    nand-sata-install # do not poweroff at the end    # clear the boot loader signature on the SD card    dd if=/dev/zero of=/dev/mmcblk0 bs=1024 seek=8 count=1    poweroff* remove microSD card* power the board, watch logs on console, login (either from console or SSH),congrats, you're running (armbian f>  lavor of) debian!2/ install freedombox, following instructions from https://wiki.debian.org/FreedomBox/Hardware/Debian   sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox-setup   sudo touch /etc/apt/apt.conf.d/50unattended-upgrades #see below   sudo /usr/lib/freedombox/setup | tee freedombox-setup.log   last command failed with   [2018-11-11 22:17:54,758] plinth.actions ERROR    Error executing command - ['sudo', '-n', '/usr/share/plinth/actions/upgrades', 'enable-auto'], ,   Error: Could not configure unattended-upgrades.   until I ran "sudo touch /etc/apt/apt.conf.d/50unattended-upgrades"reboot (once or twice, I'm not sure what happened) and plinth is now accessible using a web browser.3/ enjoy freedombox.At this point I noticed that syncthing is not available on this plinth version, and that armbian does not seem to provide buster images. I'm not sure what I'll do._______________________________________________> Freedombox-discuss mailing list> Freedombox-discuss at alioth-lists.debian.net> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/freedombox-discuss-- Regards,Joseph Nuthalapati
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20181112/73b74afc/attachment.html>

More information about the Freedombox-discuss mailing list