[Fusioninventory-user] Deploying software with FusionInventory 9.1 + 1.1 plugin for GLPI

James M. Pulver jmp242 at cornell.edu
Tue Jul 18 17:17:09 UTC 2017

I used to use Fusion Inventory for deploying packages, I think I may 
have written some of that guide. However, ever since 0.85 it's gotten so 
broken that I ended up moving my software deployment to puppet + 
chocolatey for Windows. I think in the latest versions they do support 
ad hoc tests, but really, I get the feeling it's not designed to focus 
on software deployments, but rather tasks that I never could work out 
how to get them to work reliably. I'd be interested to know if you get 
it worked out, but I'm pretty happy using a "real package manager" and 
puppet for this now.

Do you get any errors reported? Is the agent checking in regularly (I 
always set back to 1hr instead of every 24hr)? Have you forced an agent 
run on the Windows side?

James Pulver
CLASSE Computer Group
Cornell University

On 07/18/2017 12:00 PM, Gerhard Mourani wrote:
> Hello,
> I'm using FusionInventory 9.1 + 1.1 plugin with GLPI 9.1.5 and would like to deploy software. I've tried to follow instructions as described on the documentation but information from this document is outdated (http://fusioninventory.org/documentation/tasks/deploy/) and do not represent latest FusionInventory version. So I've started to do it from what I can imagine without success.
> 1 - Go to Deploy | Package management and added/created a new package (Firefox.exe to test).
> 2 - Then, go to Tasks | Task management and created a new task 'Task management' with following entries:
>        Name : Deployment test
>        Active : Checked
>        Re-prepare a target-actor if previous run is successful : Checked
>        Timeslot : 24x7
>        Agent wakeup interval : 7
>       Number of agents to wake up : 10
>       The rest of the fields are empty.
> 3 - After that, I created a new 'Jobs configuration' with following entries:
>       Name: Firefox deploy
>       Module method: Package deploy
>       Targets : My package I've created at step 1
>       Actors : One of my Windows computer
> 4 - I've restarted the fusion inventory init script but since now, no firefox package installed on my Windows machine.
> I don't know if I've forgetter something in my steps, thanks.
> Regards,
> _______________________________________________
> Fusioninventory-user mailing list
> Fusioninventory-user at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/fusioninventory-user

More information about the Fusioninventory-user mailing list