[Nut-upsdev] newhidups renaming and related (was: newhidups: merged
aquette.dev at gmail.com
Fri Oct 7 22:26:08 UTC 2005
2005/9/25, Peter Selinger <selinger at mathstat.dal.ca>:
> Arnaud Quette wrote:
> > Some more points while you're at it:
> > - newhidups will have to be renamed. My aimed was to let the name until
> > can superceed hidups. Then remove hidups, and rename newhidups to
> > (name proposition welcomed, but should match the fact that it's for
> > compliant devices, not USB only).
> It seems that some combination of "nut", "ups", "usb", and "hid" is
> needed. The name should also be reasonably short and pronouncable.
> How about "nuthid"? I personally would prefer the name to contain
> "USB", because "HID" is a technical term from the USB specification
> that does not mean anything to users. But I understand the need to
> indicate somehow that the driver does not work for all USB devices.
> Your "usbhid-ups" also achieves this goal, as does "nut-hidusb" or
> "nut_generic_usb" etc. A conservative choice would be to rename
> "newhidups" as "nuthidups".
the best choice IMO is to have:
- "usb" as it's an USB driver
- "hid" is it only support HID compliant (not only capable ;-) UPSs
- "ups" for consistency with other meta drivers (snmp-ups and genericups
(=>should be renamed to generic-ups?)).
So usbhid-ups seems the best. Postponed to svn switch
Another big step will be the switch to libhid. IIRC, I have something...
somewhere on my disk. Just got to find it back!
> - if you have a bit more time to check for the hotplug detection (linux
> > only) / files installation (the files libhid.usermap and libhidups,
> > scripts/hotplug ).
> Last time I checked this, it worked fine.
It was more a "please, check for completion of .usermap" ;-)
> These two files should also be renamed to something more
> > generall. IIRC, Charles tripplite_usb driver also use libusb, so
> > these to nut / nut.usermap, or ups / ups.usermap should be fine
> Sure, why not?
I'm still unsure about the final name here: nut or nutusbups?
Anyhow, postponed to svn switch
> Note that there seems to be some hotplug-ng (now binary) underway. So
> > some hotplug files changes too... To be digged.
> I would keep the current files in any case. In the future, one can add
> a scripts/hotplug-ng directory, if the need arises (and somebody is
> willing to contribute the scripts).
that was also implied ;-)
We must always keep a transition period in nut, as with 1.x and 2.x, except
with the driver names ;-)
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Nut-upsdev