[Nut-upsdev] NUT and Automake

Peter Selinger selinger at mathstat.dal.ca
Tue Oct 17 21:31:54 UTC 2006

Charles Lepple wrote:
> On 10/17/06, Peter Selinger <selinger at mathstat.dal.ca> wrote:
> > Charles Lepple wrote:
> > > Peter: do you know the minimum required versions of autoconf and
> > > automake for your changes?
> >
> > Unfortunately, I don't have that information (finding out would
> > require installing older versions and trying them). I am using
> > autoconf 2.59 and automake 1.9.6, which are more or less the most
> > current versions (I think?).
> I wasn't trying to make more work for you, honest. I think Debian has
> automake back to 1.4, and the reason I mention it is that older
> versions often get set as default. I don't think it's unreasonable to
> say that we "require" autoconf 2.59+ and automake 1.9+ even if it
> might work with automake 1.9.

I discovered some older versions of automake on my machine, and
tested. Automake-1.6 and older fail hopelessly. Automake-1.7.9 almost
worked, and with some minor tuning, I could get it to work perfectly.
I just committed the corresponding changes to the "automake" branch.

So the build system now works with automake-1.7.9+. 

I have not yet done a corresponding test for autoconf. However,
autoconf-2.59 was released in December 2003, so this should be no
-- Peter

More information about the Nut-upsdev mailing list