[Nut-upsdev] Patch to support GE EP series

Danilo Godec danilo.godec at agenda.si
Sat Apr 16 16:23:06 UTC 2011

On 16.4.2011 11:41, Arjen de Korte wrote:
> Citeren Danilo Godec <danilo.godec at agenda.si>:
>>> If the UPS really only uses the RX and TX pins, the setting of
>>> 'cablepower' is irrelevant.
>> Yes, the supplied RS232 cable only has three connected pins. Without
>> setting 'cablepower=none', the driver didn't detect the UPS.
> Again, the driver itself doesn't care about this setting, this is
> purely for the UPS. What could be happening is that you have a 'smart'
> connector that attaches to the serial port and requires this setting
> to power a small circuit in the connector. I could also be that this
> setting prevents another program from probing/messing with the serial
> port. You're not running something like Modem Manager are you?

No Modem Manager or anything else using the /dev/ttyS0. I thougt this
setting has something to do with flow control (RTS / CTS) and that it
had to be turned off because these pins are not used / connected.

I checked the cable with a multimeter and it looks like a
straight-through three wire cable...

> [...]
>> I tried 'cypress', 'krauler', 'ippon' and 'phoenix'. The driver only
>> detects the UPS with 'phoenix'.
> Right, I just wanted to know if you actually tried the other
> subdrivers. Clearly, the right one for this model is the 'phoenix' type.

There are some 'send timeout' messages with ''blazer_usb -DDDDDD -a
myups -x subdriver=phoenix'. Is this of any importance?


More information about the Nut-upsdev mailing list