[Nut-upsdev] Problems with blazer_usb. Driver will not shut down my UPS

hyouko at gmail.com hyouko at gmail.com
Sat Jan 4 02:18:51 UTC 2014

(Keep the list CCed)

2014/1/4 Eirik Skorstad <eskorsta at hotmail.com>:
> Hash: SHA1
>> Assuming shutdown.return works when issued via upscmd (does it
>> work?), the problem seems to be that your UPS doesn't accept a
>> shutdown.stop when there's no shutdown pending (or, maybe, the UPS
>> doesn't support it at all), therefore the shutdown sequence cannot
>> continue and issue the shutdown.return command. That problem has
>> been addressed in commit:
>> https://github.com/networkupstools/nut/commit/d079be2e4aab3c1999d99e87d70de5ee24309a31
>>  It should be available in 2.7.1
> Thanks for the answer. When i run upscmd -u user -p pass <ups-name>
> shutdown.return it returns back "OK", but in the syslog there's
> another story:
> upsd[2783]: Instant command: nutmon at did shutdown.return on
> powerwalker
> blazer_usb[2781]: instcmd: command [shutdown.return] failed

Apart from what the logs say, has the command some effects on the UPS?
Can you please launch the driver with debug level = 3 and send the
logs of when you execute the command shutdown.return via upscmd?

I saw your new UPS is shipped with ViewPower (developed by Voltronic
Power, mainly for their UPSes), so, if it's manufactured by Voltronic
Power maybe it's using their new protocol 'QGS' (mapped as 'voltronic'
in the new driver nutdrv_qx - available in 2.7.1) or one of their
other ones.
Maybe the command itself is accepted by the UPS, but since it may use
'(ACK'/'(NAK' replies instead of the 'ACK'/'echoing back' of Q1 units
the driver sees the '(ACK' as a failure.
This problem has been addressed in blazer in 2.7.1:


> When I run test.battery.start.quick it starts with the quick test, so
> something is definitely working.
> I really can't believe that a online UPS lacks this function while my
> cheep line-interactive got it.. Maybe I will have to write a mail to
> BlueWalker GmBh to see if they can answer med about the shutdown
> function.
> Is it possible to upgrade to 2.7.1 from apt or do I have to compile it
> from source?

I'm not using ubuntu.. however, here's some .deb:


> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
> 5R74VzabCWmF+zGp7EhexwWIRciJKF96C801RkueQTHtzb9IzGugXUnUBQkCRhJz
> p+vjMokWNHXl3Rb7ygaPIcVvMp17iSiKW4PotoO9wQvru6d4IIlx6XeXjY7CkOnF
> +YXGQdYmSLVn35+VdyhcNMarQRgPaEozQUX65PmllCapMX0TGWsDNdfTvNVQFw+N
> SaSoiQtCmtI+4aBEgvspyCQo3cRElDYPukdIcdW/ywdm2JzxPkQy+AVN/4ySAeVD
> tOsoYy0ef1ZGM2z3SX9VeT4ETDzS44ZrBiEUXIR3MIj6ejOZd1c/cSG+8rkjm2A=
> =0aqD

More information about the Nut-upsdev mailing list