[Nut-upsdev] [PATCH 2/3] Add generic facility to override HID report descriptor in usbhid-ups
clepple at gmail.com
Sun Mar 4 23:58:43 UTC 2018
On Feb 3, 2018, at 7:19 PM, Russell King wrote:
> + addvar(VAR_VALUE, "hid_descriptor", "Replacement HID descriptor file");
I was adding a quick note to the usbhid-ups man page about this parameter, and I had a few thoughts:
* Maybe we should call it "read_hid_descriptor_file", and have a complementary "write_hid_descriptor_file" option? We don't need the corresponding write code now, but I don't want to rename the read side after releasing it.
* I'm wondering if we should require users to specify at least the length of the descriptor they are replacing (and possibly more info, like a checksum that the driver could print out in debug mode). My concern is that someone is going to post their replacement descriptor online, and someone else will just blindly use it without verifying that it is indeed for their firmware revision. This case is not as uncommon as one would hope, especially given how line-powered UPS hardware changes while the model names stay the same.
More information about the Nut-upsdev