[Nut-upsuser] Problems starting upsd with newhidups

John Gruenenfelder johng at as.arizona.edu
Mon Feb 27 22:04:21 UTC 2006

On Mon, Feb 27, 2006 at 08:07:45PM +0100, Arnaud Quette wrote:
>2006/2/25, John Gruenenfelder <johng at as.arizona.edu>:
>> I read the two bug reports and it certainly seemed like the likely culprit.
>> However, after I installed the 2.0.3-2 packages the problem remains.  The
>> symptoms are unchanged from my original email.  I still get:
>ok, I think we were on the wrong way. the below one should be the
>source of the problem:
>To validate, search for the right /proc/bus/usb/X/Y (where X and Y can
>be looked up with lsusb) and check the right of it. It should still be
>Changing this to root:nut (and 660) should solve the isssue...
>I'll wait a bit more and upload -3 tomorrow.

Yup, that did the trick.  Thanks!
At first, I tried running "upsd -u root" to verify and it still didn't work.
But everything ran fine when I used the init script.

In order for the programs to be happy, I still had to modify the init script
to add "-u root" to the start-stop-daemon command which runs upsd:

start-stop-daemon -S -q -p $upsd_pid -x $upsd -- -u root >/dev/null 2>&1

Is there a better way to do this?  Or do I need to adjust some file
permissions someplace?  NUT was originally installed on this machine in
September even though I had not yet started using it.  So if the permissions
are wrong, it could be the result of some cruft left over from then... maybe?

--John Gruenenfelder    Research Assistant, UMass Amherst student
                        Systems Manager, MKS Imaging Technology, LLC.
Try Weasel Reader for PalmOS  --  http://gutenpalm.sf.net
"This is the most fun I've had without being drenched in the blood
of my enemies!"
        --Sam of Sam & Max

More information about the Nut-upsuser mailing list