[Nut-upsuser] nut 2.0.4 won't compile on AIX 5.3

Jurjen Oskam jurjen at stupendous.org
Wed Oct 18 10:54:08 UTC 2006

Hi there,

I'm trying to compile nut 2.0.4 on an AIX 5.3 machine, but it fails:

$ make
        /usr/vac/bin/cc -I../include -O -c common.c
        /usr/vac/bin/cc -I../include -O -c upsconf.c
        /usr/vac/bin/cc -I../include -O -c parseconf.c
        /usr/vac/bin/cc -I../include -O -c state.c
Target "all" is up to date.
        /usr/vac/bin/cc -I../include -O -c bestups.c
"serial.h", line 11.4: 1506-205 (S) #error "No <sys/termios.h> available.
Unable to continue."
"serial.h", line 20.45: 1506-046 (S) Syntax error.
"bestups.c", line 405.43: 1506-045 (S) Undeclared identifier B2400.
make: The error code from the last command is 1.

make: The error code from the last command is 1.


The config.log file is on http://www.stupendous.org/config.log . This error
(and the config.log file I mentioned) occurred using the IBM C compiler,
vac.c version 6. I also tried using gcc 3.3.2, but it failed in the same
way. The AIX version is 5.3, TL4-CSP.

Since the AIX machines only need to talk to a upsd on another machine
(Linux), I don't even need the serial things to work. So, I also tried
to compile without any drivers ("--with-drivers="), but it still fails
when compiling dummycons.c.

If anybody could help me trying to get it to successfully compile, I'd be
happy. :)

Jurjen Oskam

Savage's Law of Expediency:
        You want it bad, you'll get it bad.

More information about the Nut-upsuser mailing list