[Nut-upsuser] nut 2.2.0 doesn't see MGE Elipse 1200 on FreeBSD 6.2

Dan Rich drich at employees.org
Thu Oct 18 18:53:07 UTC 2007

I haven't tried the patch yet, but I just found part of the problem,
it's related to the problem that was mentioned on the SUSE thread.  The
FreeBSD port configures nut as user and group uucp.  By default, the
ugen devices are root:operator.  I just added uucp to the operator group
and now it at least sees my MGE!

It looks like I'm getting data, I'll have to unplug the UPS from the
wall tonight and see if the battery starts to show that it is
discharging.  The last time I tried this, it would get the initial data
but never change until the driver was reloaded (not all that useful in
that state).

Daniel O'Connor wrote:
> On Wed, 17 Oct 2007, Charles Lepple wrote:
>> On 10/16/07, Dan Rich <drich at employees.org> wrote:
>>>  Does anyone have any thoughts as to the magic incantation to get
>>> this working?
>> I believe you need to recompile the kernel to not include the "uhid"
>> driver, so that the UPS is available as a ugen device. (In FreeBSD,
>> this should not affect the use of a USB HID keyboard or mouse.)
> Even so I doubt it will be very reliable :(
> I did create a diff that might help but noone tested it (and I don't 
> have an MGE UPS handy at the moment to test it myself)
> Note that while this will still cause data to be dropped it should a) 
> log the fact, and b) do it in a way that doesn't cause the UPS driver 
> to get out of sync.
> ugen should really be fixed to not use clist buffers but that can wait 
> for another day :)

Dan Rich <drich at employees.org> |   http://www.employees.org/~drich/
                               |  "Step up to red alert!"  "Are you sure, sir?
                               |   It means changing the bulb in the sign..."
                               |          - Red Dwarf (BBC)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20071018/7c2bb91b/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20071018/7c2bb91b/attachment-0001.pgp 

More information about the Nut-upsuser mailing list