[Nut-upsuser] nut 2.2.0 doesn't see MGE Elipse 1200 on FreeBSD 6.2

Arnaud Quette aquette.dev at gmail.com
Thu Oct 25 19:43:33 UTC 2007

2007/10/18, Daniel O'Connor <doconnor at gsoft.com.au>:
> On Fri, 19 Oct 2007, Dan Rich wrote:
> > I haven't tried the patch yet, but I just found part of the problem,
> > it's related to the problem that was mentioned on the SUSE thread.
> > The FreeBSD port configures nut as user and group uucp.  By default,
> > the ugen devices are root:operator.  I just added uucp to the
> > operator group and now it at least sees my MGE!
> You can use devfs rules or a devd scriptto modify the permissions on
> ugen automatically. (ie chown it nut:uucp if an MGE is plugged in)

I'm interested in any scripts to add to the scripts/ dir (like hotplug
and udev) that would make our BSD users' life easier.

> > It looks like I'm getting data, I'll have to unplug the UPS from the
> > wall tonight and see if the battery starts to show that it is
> > discharging.  The last time I tried this, it would get the initial
> > data but never change until the driver was reloaded (not all that
> > useful in that state).
> The problem in my experience is that it is not reliable :(

I can't definitly do nothing for that, sadly.
But if you know a good freebsd kernel hacker that would like to work
with us on improving ugen/libusb/nut, and get a unit to develop and
test with, I can do something...

Linux / Unix Exprt R&D - MGE Office Protection Systems - http://www.mgeops.com
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://people.debian.org/~aquette/
Free Software Developer - http://arnaud.quette.free.fr/

More information about the Nut-upsuser mailing list