[Nut-upsuser] Nut and PowerWare 5115

Greg greg_roll at hotmail.com
Thu Apr 16 00:25:58 UTC 2009

Hi everyone,

Been searching like crazy to find an answer to this. I have even read some of the source code but cannot figure this one out.

I have installed nut 2.4.1 on my QNAP 409 Pro. (command: ipkg install nut)
I have configured the ups.conf, upsd.conf and upsd.users.

When i run "upsdrvctl start" I get the following error messages and output.

Network UPS Tools - UPS driver controller 2.4.1
Network UPS Tools - BCMXCP UPS driver 0.21 (2.4.1)
USB communication subdriver 0.17
Communications with UPS lost: Receive error (data): got 33 bytes instead of 116!!!

Communications with UPS lost: Receive error (Request command): COMMAND: 31


Can't set POWERWARE USB configuration
Unable to find POWERWARE UPS device on USB bus

Things to try:

 - Connect UPS device to USB bus

 - Run this driver as another user (upsdrvctl -u or 'user=...' in ups.conf).
   See upsdrvctl(8) and ups.conf(5).

Fatal error: unusable configuration

Driver failed to start (exit status=1)

My ups.conf looks like this



driver = bcmxcp_usb

port = auto

desc = "PowerWare 5115 UPS"


baud_rate = 9600

I have tried various configurations but nothing seems to work.

Once I receive this error I need to disconnect and reconnect the USB cable to get any further.
Is there anything I can try?
UPS work correctly on a Windows Vista/2008.

Over the next few days I will try and install NUT on ubuntu 8.10 and try it on that.

Thanks for your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090416/cf39016f/attachment.htm>

More information about the Nut-upsuser mailing list