[Nut-upsuser] Nut and PowerWare 5115

Greg greg_roll at hotmail.com
Fri Apr 17 13:36:24 UTC 2009

Hi Kjell,

Thanks for the follow up. Answers below...


From: "Kjell Claesson" <kjell.claesson at epost.tidanet.se>
Sent: Friday, April 17, 2009 3:17 PM
To: "Greg" <greg_roll at hotmail.com>
Cc: <nut-upsuser at lists.alioth.debian.org>
Subject: Re: [Nut-upsuser] Nut and PowerWare 5115

> fredag 17 april 2009 01:09:58 skrev  Greg:
>> Hi Kjell,
> OK Greg,
>> Thanks for the quick responce.
>> I have removed the baud_rate. My bcmxcp_usb is located in /opt/bin.
>> (structure of the QNAP device).
>> The QNAP does not have a root user but an admin user so I ran the command
>> with -u admin.
>> Running the command I got the same output i think.
> 8<---------------------------------snip--------------------------------------
> Yep it is the same result.
>>Communications with UPS lost: Receive error (data): got 33 bytes instead 
> It looks like the usb-bus stop. But it have fund the device.
>>Communications with UPS lost: Receive error (Request command): COMMAND: 31
> And it chokes on the first command. (Line 1040 in bcmxcp.c) and loose
> connection to the device.
> It try to reconnect to the device.
>>Can't set POWERWARE USB configuration
>>Unable to find POWERWARE UPS device on USB bus
> But now it can not find it on the bus.
> Can you tell me something more about the setup.
> I'm not so familiar with QNAP.
> Based on Linux or FreeBSD ?

Everything on the net appears to say Linux.
uname -a output is "Linux THEBOX #5 Wed Mar 18 15:19:23 CST 
2009 armv5tejl unknown"

> What version of the usblib is installed?
The closest thing I could find was libusb. It is version 0.1.12-1.
IPKG lists libusb as a dependency for NUT

> Is other devices using usblib working?
To the best of my knowledge no.

> Do you have a serial port on the device ?
No unfortunately its just USB

> And if you have any link so i can read something more on QNAP devices.
This is the model I have http://www.qnap.com/pro_detail_feature.asp?p_id=85
And this is information about the ipkg installer which i used to install NUT 

Over the weekend I will install NUT on ubuntu 8.10 just to make sure it can 
connect to my UPS fine.
The Windows software can connect so I know my UPS is functioning.

Once again thank you for your help.

> Regards
> Kjell

More information about the Nut-upsuser mailing list