[Nut-upsuser] Nut and PowerWare 5115

Kjell Claesson kjell.claesson at epost.tidanet.se
Fri Apr 17 05:17:15 UTC 2009

fredag 17 april 2009 01:09:58 skrev  Greg:
> Hi Kjell,

OK Greg,
> Thanks for the quick responce.
> I have removed the baud_rate. My bcmxcp_usb is located in /opt/bin.
> (structure of the QNAP device).
> The QNAP does not have a root user but an admin user so I ran the command
> with -u admin.
> Running the command I got the same output i think.

Yep it is the same result. 

>Communications with UPS lost: Receive error (data): got 33 bytes instead of 
It looks like the usb-bus stop. But it have fund the device.

>Communications with UPS lost: Receive error (Request command): COMMAND: 31

And it chokes on the first command. (Line 1040 in bcmxcp.c) and loose 
connection to the device.


It try to reconnect to the device.
>Can't set POWERWARE USB configuration
>Unable to find POWERWARE UPS device on USB bus
But now it can not find it on the bus.

Can you tell me something more about the setup.
I'm not so familiar with QNAP. 
Based on Linux or FreeBSD ?
What version of the usblib is installed?
Is other devices using usblib working?
Do you have a serial port on the device ?

And if you have any link so i can read something more on QNAP devices.


More information about the Nut-upsuser mailing list