[Nut-upsuser] HP T1000 UPS Upadet & help with using under knoppix

stephen_b_allen at tiscali.co.uk stephen_b_allen at tiscali.co.uk
Mon Apr 27 15:03:36 UTC 2009

Hello all,

First the easy bit, using the info in these mailing lists in respect 
of HP T750 here is the info for the T1000:
Checking device (03F0/1F08) (003/006)
FCC no of 5WSUSA-33229-XP-E , suggest it is a tripplite

Added the T1000 info to tripplite-hid.c as described recompiled and 
works fine, thank you.

Which driver should I use if I want to connect via the serial port? I 
am using the usbhid-ups driver via usb at present.

Next, would anyone be prepared to help to get NUT to work under a re-
mastered knoppix 5.3.1 CD.?

I'll list what I have achieved so far.

Install knoppix to hdd ( install script standard with knoppix)
Installed headers, libusb++-dev, libgd2-apm-dev & libupsclient1, all 
Download nut-2.4.1.tar.gz, run config - make -make install
Everything works ok & can connect to T1000 !!!!!!

Repeat everything in the chroot re-master environment (removed header 
etc after compiling nut), everything OK and build re-master cd.
Boot from knoppix live cd and get these problems (on same PC as 
knoppix hdd install):
	Upsdrvctl  start 
After a few minutes I get an error of:
	Startup timer elapsed, continuing…..

At this stage I find that lsusb now locks up and upon further 
investigations I find that /dev/usb/hiddev0 has now been deleted 
(including the directory /dev/usb)

Re-boot is necessary.
Run lsusb & HP 1000 is found
Change permissions on /dev/usb to full read/write access & the same to 
./lib/nut/usbhid-ups -DDD -u root -a testups
I get a summary of:
Checking device  (03F0/1F08) (003/003)
- Vendor ID: 03f0
-Product ID: 1f08
- Manufacturer: Hewlett Packard
-Product: T1000 INTL
-Serial No: 2CJ8etc
-Bus: 003
Trying to match device
Device matches
Failed to claim usb device: could not claim interface 0: Device or 
resource busy.

/dev/usb directory deleted as well as file/dev/usb/hiddev0

Usb mouse still works but lsusb now locks up terminal not complete OS.
Searched the lists on "Failed to claim usb…" , found lots of info on 
this but nothing I could use, especially as it works from hdd install.
Although I boot from CD, I can of course change all the 
permissions/rights etc and I feel this is the first area I should look 

Also tried the following after a google:
1 - Remove user root from my upsd.users
2 - ./usbhid-ups -u root -DD -a testups
Now get a slightly different:
etc etc....Device matches
failed to claim usb device: could not claim interface 0: Operation not 
failed to detach kernel driver from USB device: could not deteach 
kernel driver from interface 0: Operation not permitted
This repeated 5 times. But now /dev/usb/hiddev0 has not been deleted & 
lsusb runs and displays the UPS.
Howerver, if I run sudo ./usbhid-ups -u root -DD -a testups, I'm all 
locked up agagin as described above.

Final question, I have also tried nut-2.2.2.tar.gz, can the t750 & 
T1000 be added. The driver files look so different. Can this version of 
nut be patched?

Any ideas?



News, Entertainment, Celebrity Gossip and more - http://www.tiscali.co.uk

More information about the Nut-upsuser mailing list