[Nut-upsuser] Powerware 5110 UPS with nut in Ubuntu

Greg Vickers daehenoc at optusnet.com.au
Sun Jul 12 10:24:52 UTC 2009

Hi Kjell,

Kjell Claesson wrote:
>> Hi all,
> Hi Greg,
>> I've got a Powerware 5110 UPS that I'm trying to set up with nut in
>> Ubuntu.  I've installed nut and configured the first two files:
>> $ cat /etc/nut/nut.conf
>> MODE=standalone
>> $ cat /etc/nut/ups.conf
>> [pw5110]
>> 	driver = bcmxcp_usb
>> 	port = auto
>> #	port = /dev/bus/usb/002/002
> Yes the port should be auto.
> And if you use the latest libusb you should have a device
> at /dev/bus/usb/002/002 that you have found.
>> When I try to test this configuration with the following command:
>> $ sudo upsdrvctl start pw5110
>> Network UPS Tools - UPS driver controller 2.4.1
>> Network UPS Tools - BCMXCP UPS driver 0.21 (2.4.1)
>> USB communication subdriver 0.17
>> Can't set POWERWARE USB configuration
>> Unable to find POWERWARE UPS device on USB bus
> To make a real test that it read the usb you can do the following.
> Set libusb debug to 3.
> sudo export LIBUSB_DEBUG=3
> Then run the driver in debug (not by upsdrvctl).
> sudo /path/to/bcmxcp_usb -DD -u -a pw5110
> Now it should spit out some info. You end it by ctrl-c.
> Report back and we can have a look.
> We may have a bug here, but it is not confirmed as our tests
> does not reveal it.

After leaving my Ubuntu host overnight, I've turned it on and the nut 
daemon was running when I tried the above check.  I stopped that daemon 
and the above test worked just fine!  I didn't change anything and now 
it's working just fine.

Thank you for the information about the debug test!  All OK now! :)


More information about the Nut-upsuser mailing list