[Nut-upsuser] Powerware 5110 UPS with nut in Ubuntu

Arnaud Quette aquette.dev at gmail.com
Thu Jul 16 21:11:48 UTC 2009

Hi Greg

first, a thank to Kjell too...

2009/7/12 Greg Vickers <daehenoc at optusnet.com.au>

> Hi Kjell,
> Kjell Claesson wrote:
>> Hi all,
>> Hi Greg,
>>  I've got a Powerware 5110 UPS that I'm trying to set up with nut in
>>> Ubuntu.  I've installed nut and configured the first two files:
>>> $ cat /etc/nut/nut.conf
>>> MODE=standalone
>>> $ cat /etc/nut/ups.conf
>>> [pw5110]
>>>        driver = bcmxcp_usb
>>>        port = auto
>>> #       port = /dev/bus/usb/002/002
>> Yes the port should be auto.
>> And if you use the latest libusb you should have a device
>> at /dev/bus/usb/002/002 that you have found.
>>> When I try to test this configuration with the following command:
>>> $ sudo upsdrvctl start pw5110
>>> Network UPS Tools - UPS driver controller 2.4.1
>>> Network UPS Tools - BCMXCP UPS driver 0.21 (2.4.1)
>>> USB communication subdriver 0.17
>>> Can't set POWERWARE USB configuration
>>> Unable to find POWERWARE UPS device on USB bus
>> To make a real test that it read the usb you can do the following.
>> Set libusb debug to 3.
>> sudo export LIBUSB_DEBUG=3
>> Then run the driver in debug (not by upsdrvctl).
>> sudo /path/to/bcmxcp_usb -DD -u -a pw5110
>> Now it should spit out some info. You end it by ctrl-c.
>> Report back and we can have a look.
>> We may have a bug here, but it is not confirmed as our tests
>> does not reveal it.
> After leaving my Ubuntu host overnight, I've turned it on and the nut
> daemon was running when I tried the above check.  I stopped that daemon and
> the above test worked just fine!  I didn't change anything and now it's
> working just fine.
> Thank you for the information about the debug test!  All OK now! :)

well, ok now, but there is still something under the hood!
my guess is that the udev update change introduced by Scott James doesn't
fully refresh the udev rights.
I've not taken the time to validate it though, so mea culpa.
the result is basically that if you don't unplug/replug your device or
reboot your system after nut installation, the udev rule is not applied.

I'll try to check that tomorrow, and make some more progress on 2.4.1-4,
which will be a major Debian update.

Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/
Conseiller Municipal - Saint Bernard du Touvet -
en charge de la Communication, de l'Informatique et des Technologies
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090716/0e2913d3/attachment.htm>

More information about the Nut-upsuser mailing list