[Nut-upsuser] Problems connecting via USB to APC Back-UPS ES 700 (Model BE700-GR)

Arnaud Quette aquette.dev at gmail.com
Mon Jul 27 07:17:58 UTC 2009

Hi Christoph,

2009/7/27 Christoph Loesch <info at loesch.me>

> hi list,
> im running debian/testing(act. squeeze) with 2.6.26-2-amd64 kernel. first
> tried apcupsd what flawlessly worked but because i run nagios (needs nut
> running for 'check_ups'), im trying to run nut.
> dmesg and syslog show the device:
> Jul 27 00:08:06 kate kernel: [16001.477941] hiddev96hidraw0: USB HID v1.10
> Device [APC Back-UPS ES 700 FW:829.D3 .I USB FW:D3 ] on usb-0000:00:1d.1-1
> Jul 27 00:08:06 kate kernel: [16001.477941] usb 3-1: New USB device found,
> idVendor=051d, idProduct=0002
> Jul 27 00:08:06 kate kernel: [16001.477941] usb 3-1: New USB device
> strings: Mfr=3, Product=1, SerialNumber=2
> Jul 27 00:08:06 kate kernel: [16001.477941] usb 3-1: Product: Back-UPS ES
> 700 FW:829.D3 .I USB FW:D3
> Jul 27 00:08:06 kate kernel: [16001.477941] usb 3-1: Manufacturer: APC
> Jul 27 00:08:06 kate kernel: [16001.477941] usb 3-1: SerialNumber:
> 3B0908X39177
> lsusb doesnt show it. (maybe because usb is statically compiled in?)
> kate:/# grep -w CONFIG_USB /boot/config-`uname -r`
> but the hiddevice is there
> kate:/# ls -la /dev/hid*
> crw-rw-r-- 1 root root 180, 96 27. Jul 00:08 /dev/hiddev0
> crw-rw---- 1 root root 250,  0 27. Jul 00:08 /dev/hidraw0
> tried using usbhid-ups driver and even with setting the option variable
> "cable" to "940-0127E" i had no luck.
> genericups with all possible upstypes doesnt work either.
> any ideas?
> chris

NUT' USB drivers use the libusb, so the usbfs on Linux (ie

depending on your exact distro version, the udev rule is located in
/etc/udev/rules.d (old path) or /lib/udev/rules.d (new path). Generally,
putting "auto" as the port value is sufficient.

to make a quick test, launch the driver as root, ie:
/path/to/usbhid-ups -u root -a upsname

it should acquire the connexion and talk to the device.
if it's ok, also try lsusb as root, you should see your device. then check
the devices permissions, with the info from lsusb (Bus XXX, Device YYY) on
it should be sufficient for the "nut" user (the exact user name depends on
the distro...)

Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090727/59fb34a5/attachment.htm>

More information about the Nut-upsuser mailing list