[Nut-upsuser] blazer_usb - short reply

Andrew Zabolotny zap at homelink.ru
Tue Mar 17 21:58:31 UTC 2009


I'm trying to use nut with a Ippon Smart Winner 3000 UPS
(http://shop.key.ru/photo/items/45535.jpg) which looks like a
custom-labeled OEM model of the megatec branch.

I tried both the megatec_usb and the blazer_usb drivers for it, with a
obvious config section:

driver = blazer_usb
port = auto
vendorid = 06da
productid = 0003
desc = "Ippon Smart Winner 3000"

If I run blazer_usb -a ippon -DDDDD I get the following:

debug level is '5'
Checking device (06DA/0003) (002/011)
- VendorID: 06da
- ProductID: 0003
- Manufacturer: unknown
- Product: USB UPS
- Serial Number: unknown
- Bus: 002
Trying to match device
Device matches
failed to claim USB device: could not claim interface 0: Device or
resource busy detached kernel driver from USB device...
Trying megatec protocol...
send: Q1
read: (218.7 218.7 218.7 020 50.0 0110 54.8 00001000
send_to_all: SETINFO input.voltage "218.7"
send_to_all: SETINFO input.voltage.fault "218.7"
send_to_all: SETINFO output.voltage "218.7"
send_to_all: SETINFO ups.load "20"
send_to_all: SETINFO input.frequency "50.0"
send_to_all: SETINFO battery.voltage "110.00"
send_to_all: SETINFO ups.temperature "54.8"
send_to_all: SETINFO beeper.status "disabled"
send_to_all: SETINFO ups.type "offline / line interactive"
send_to_all: SETINFO ups.status "OL"
Status read in 1 tries
Supported UPS detected with megatec protocol
send: error sending control message: Connection timed out
blazer_rating: short reply
Rating read 1 failed
Checking device (06DA/0003) (002/011)
- VendorID: 06da
- ProductID: 0003
- Manufacturer: unknown
- Product: unknown
- Serial Number: unknown
- Bus: 002
Trying to match device
Device does not match - skipping
Checking device (0000/0000) (002/001)
... here it goes over all USB devices, despite the fact that I have
pointed the vendor/product ids in the config ...
Checking device (0000/0000) (001/001)
- VendorID: 0000
- ProductID: 0000
- Manufacturer: Linux 2.6.18-92.1.22.el5.centos.plus ehci_hcd
- Product: EHCI Host Controller
- Serial Number: 0000:00:03.2
- Bus: 001
Trying to match device
Device does not match - skipping
No appropriate HID device found
blazer_vendor: short reply
Vendor information read 3 failed
Vendor information unavailable
Battery runtime will not be calculated (runtimecal not set)
send_to_all: SETINFO ups.delay.start "180"
send_to_all: SETINFO ups.delay.shutdown "30"
send_to_all: ADDCMD beeper.toggle
send_to_all: ADDCMD load.off
send_to_all: ADDCMD load.on
send_to_all: ADDCMD shutdown.return
send_to_all: ADDCMD shutdown.stayoff
send_to_all: ADDCMD shutdown.stop
send_to_all: ADDCMD test.battery.start
send_to_all: ADDCMD test.battery.start.deep
send_to_all: ADDCMD test.battery.start.quick
send_to_all: ADDCMD test.battery.stop
send_to_all: SETINFO ups.vendorid "0000"
send_to_all: SETINFO ups.productid "0000"
blazer_status: short reply
Communications with UPS lost: status read failed!
dstate_init: sock /var/run/nut/blazer_usb-ippon open on fd 5

...and over and over again...

So it looks like the driver talks properly with the UPS (and reads the
voltage, temperature etc properly), but at some point the interaction is
being suddenly interrupted (blazer_rating: short reply), then it
reconnects again and so on in a endless loop.

What I can do to locate and fix the problem?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090318/4f150077/attachment.pgp 

More information about the Nut-upsuser mailing list