[Nut-upsuser] USBDEVFS_CONTROL failed cmd usbhid-ups

Thomas Gutzler thomas.gutzler at gmail.com
Wed Nov 25 10:51:09 UTC 2009


thanks for your input, it's highly appreciated.

Arjen de Korte wrote:
> Citeren Thomas Gutzler <thomas.gutzler at gmail.com>:
>>> Nov 23 11:38:08 io kernel: [763936.976568] usb 3-2: usbfs:
>>> USBDEVFS_CONTROL failed cmd usbhid-ups rqt 161 rq 1 len 2 ret -71
> Older devices (actually, USB implementations in the UPS) seem to suffer more from the above than newer ones. 

Interesting. The device that generates all the errors is just a month
old (ups.mfr: EATON). The 2 year old UPS (ups.mfr: MGE UPS SYSTEMS)
works just fine.

> One thing you could try, is to see if increasing 'pollfreq' to 120 for
> this driver instance reduces the number of occurrences in the log.
> Chances are, the UPS chokes on the large amount of data it needs to
> process when we poll for all variables every 'pollfreq' seconds. It will
> still poll for the most important status bits every 'pollinterval'
> anyway, so you don't risk missing out on critical events. Note that this
> won't fix the problem, it just limits the impact.

I have set pollfreq to 120; wasn't aware that there is an event based
messaging system in place next to the polling. I also tried changing
ups.test.interval (as suggested by Arnaud) but it didn't exist and the
only other interval variable I found is driver.parameter.pollinterval,
which I changed from 2 to 4.

I have tried different USB ports, with no success.


More information about the Nut-upsuser mailing list