[Nut-upsuser] [Bug 447586] [NEW] megatec_usb does not work anymore with a Trust PW-4130M UPS

Arnaud Quette aquette.dev at gmail.com
Sat Oct 10 07:54:58 UTC 2009

Hi Björn,

2009/10/9 Björn Torkelsson

> Public bug reported:
> Binary package hint: nut
> I have recently upgraded from hardy to intrepid to jaunty. After
> upgrading to Intrepid the megatec_usb stopped recognizing my Trust PW-
> 4130M ups, it still does not work on Jaunty. It worked without any
> problems in hardy.
> I tried the megatec_usb driver from hardy and it detects the ups.
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> Package: nut 2.4.1-2ubuntu4 [modified: usr/share/nut/driver.list
> lib/nut/megatec_usb]
> SourcePackage: nut
> Uname: Linux 2.6.28-15-server x86_64
> ** Affects: nut (Ubuntu)
>     Importance: Undecided
>         Status: New
> ** Tags: amd64 apport-bug
> --
> megatec_usb does not work anymore with a Trust PW-4130M UPS
> https://bugs.launchpad.net/bugs/447586
> You received this bug notification because you are subscribed to nut in
> ubuntu.

(leaving the full bug report for the NUT team)

I vaguely remember something with this driver and the default subdriver
Alex may have more info.

can you check the latest development version (subversion trunk).
For more info on getting and compiling the development release:

Note that you don't need to install nut ; simply running from the build
directory is sufficient, using:
$ sudo ./drivers/megatec_usb -DDDDD -a <upsname>

you might also give a try to blazer_usb, which will replace megatec*
$ sudo /lib/nut/blazer_usb -DDDDD -a <upsname>
$ sudo ./drivers/blazer_usb -DDDDD -a <upsname>

Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20091010/6ab7aa01/attachment-0001.htm>

More information about the Nut-upsuser mailing list