[Nut-upsuser] Battery test feature of APC Back-UPS RS series

Jean Delvare khali at linux-fr.org
Sat Oct 10 13:41:07 UTC 2009

Hi Arjen,

On Sat, 10 Oct 2009 15:09:58 +0200, Arjen de Korte wrote:
> Citeren Jean Delvare <khali at linux-fr.org>:
> > I'm testing it now. The new driver indeed shows new commands:
> >
> > test.battery.start.deep - Start a deep battery test
> > test.battery.start.quick - Start a quick battery test
> > test.battery.stop - Stop the battery test
> Good. You seem to be running the latest version from the trunk.

Yes I am.

> > But upscmd fails with:
> >
> > # upscmd rs800 -u admin test.battery.start.quick
> > Error: old command names are not supported
> Not surprising. The order of command line options is wrong. The  
> correct order would be
>      upscmd -u admin rs800 test.battery.start.quick
> See 'man 8 upscmd'.

D'oh. Shame on me, sorry for the noise.

Maybe the error message could be a little more helpful though?

Now the good news: the battery test command appears to work!

The test.battery.start.quick command behaves exactly as when using
APC's own software. The battery is being tested for a few seconds, then
the UPS returns online, and ups.test.result is set to "Done and
passed". Perfect.

I am a little skeptical about the test.battery.start.deep command. When
I run it, the UPS switches to battery. After one second, nut tells me
I'm on battery, and one second later that I am back online. However,
the UPS is _still_ on battery, I can see it on the front panel (and I
can hear it, too.) Then I waited some more and nothing changed. After a
minute I had to issue a test.battery.stop command to return online. It
worked OK, but now ups.test.result is set to "Aborted". So maybe I
wasn't supposed to stop it? How long is it supposed to last? I couldn't
find documentation on how the deep test is supposed to behave.

After that I couldn't issue a test.battery.start.deep command again,
nothing happened when I tried. test.battery.start.quick still works

As a summary it seems that test.battery.start.quick works just fine,
while test.battery.start.deep may need some quirks (if possible at all.)

Thanks a lot for your help Arjen (and Arnaud, and Charles)! I'm really
happy to have the battery test feature working now.

If you need me to run any additional test, please let me know and I'll
help as much as possible.

Jean Delvare

More information about the Nut-upsuser mailing list