[Nut-upsuser] Battery test feature of APC Back-UPS RS series

Arjen de Korte nut+users at de-korte.org
Sat Oct 10 13:57:24 UTC 2009

Citeren Jean Delvare <khali op linux-fr.org>:

> Now the good news: the battery test command appears to work!

That's good to hear.

> The test.battery.start.quick command behaves exactly as when using
> APC's own software. The battery is being tested for a few seconds, then
> the UPS returns online, and ups.test.result is set to "Done and
> passed". Perfect.


> I am a little skeptical about the test.battery.start.deep command. When
> I run it, the UPS switches to battery. After one second, nut tells me
> I'm on battery, and one second later that I am back online. However,
> the UPS is _still_ on battery, I can see it on the front panel (and I
> can hear it, too.)

While this may seem confusing, this is actually what it is supposed to  
do. After all, the OL/OB flag only tells you something about the line  
status and when you run this command, most likely that is not  
changing. So during the test, it is actually correct that the OL flag  
is set (so 'online' would be correct).

> Then I waited some more and nothing changed. After a
> minute I had to issue a test.battery.stop command to return online.

You probably need to be more patient. It may take quite a while for  
before the battery reaches the battery low charge.

> It worked OK, but now ups.test.result is set to "Aborted".

Very good, so the test.battery.stop command also works. This seems to  
be a resounding success... :-)

> So maybe I wasn't supposed to stop it? How long is it supposed to last?
> I couldn't find documentation on how the deep test is supposed to behave.

Usually until the battery charge reaches the 'low' level, at which  
time the UPS should stop the test and resume to normal. Depending on  
the amount of time since the test was started and the load present, it  
may also inform you about the health of the battery.

> After that I couldn't issue a test.battery.start.deep command again,
> nothing happened when I tried. test.battery.start.quick still works
> though.

Weird. I have no idea why that happens.

Best regards, Arjen
Please keep list traffic on the list

More information about the Nut-upsuser mailing list