[Nut-upsuser] new variable

Arjen de Korte nut+users at de-korte.org
Wed Sep 30 11:03:23 UTC 2009

Citeren "Kiss Gabor (Bitman)" <kissg op ssg.ki.iif.hu>:

> I have to simulate a behaviour of a real UPS. The physical model
> contains an extra attribute: the charging current that needed to compute
> recharge time and actual battery charge during the recharge process.
> Can we call this variable "battery.current.recharge"?

We already have 'battery.current' and 'battery.capacity' variables, so  
you should use these instead. These allow you to simulate  
charging/discharging your virtual battery and also calculate the  
(virtual) charge it accumulates. You could base setting the LB flag on  
the 'battery.charge.low' value then.

> Or should I put it into "driver.*" name space?

Not at all. This is used for variables that are passed to drivers in  
the 'ups.conf' file. You shouldn't add these yourself.

Best regards, Arjen

PS  Please use the nut-upsdev mailing list for development related messages.
Please keep list traffic on the list

More information about the Nut-upsuser mailing list