[Nut-upsuser] NUT with Cyber Power 700 AVR

Rob Donovan hikerman2005-nut at yahoo.com
Sat Aug 7 18:22:14 UTC 2010

I applied the aforementioned patch to 2.4.3 and recompiled.  Since the 
patch only affects newmge-shut and usbhid-ups I just copied the latter 
into /lib/nut/  This works, insomuchas all the nut programs start up and 
run.  However, there are 3 remaining problems:

1) syslog errors every 20+ minutes or so like :  Aug  7 10:21:03 ben 
usbhid-ups[3321]: libusb_get_string: error sending control message: 
Broken pipe   

2) syslog errors on a similar timescale like : Aug  7 08:17:40 ben 
kernel: [40170.402789] usb 2-1.2: usbfs: USBDEVFS_CONTROL failed cmd 
usbhid-ups rqt 161 rq 1 len 8 ret -110

3) The machine spontaneously shutdown this morning due to a "low 
battery" condition.  However, 80 minutes later when I noticed the UPS 
battery was at 100%.  I don't think it can charge that fast, so I think 
this must have been a communication error.

I've now tried two versions of NUT, a patch, and both serial and usb 
communications.  Only one mode (2.2.2 usb) works in any meaningful 
sense, but even that suffered from minute+ periods of stale data in the 
few days I ran it.  I wanted to use NUT so I could hang possible future 
machines off one big ups, but for the present I give up.

Hopefully the portmon log I posted will help.  I note that both Thomas 
and I are running Debian Lenny and using recently purchased Cyberpower UPSs.

More information about the Nut-upsuser mailing list