[Nut-upsuser] Driver does not detect megatec_usb UPS

Charles Lepple clepple at gmail.com
Mon Aug 9 02:02:31 UTC 2010

On Aug 8, 2010, at 9:55 PM, Noel David Torres Taño wrote:

> Tried that driver from nut itself:
> # /lib/nut/blazer_usb -a yukai
> Network UPS Tools - Megatec/Q1 protocol USB driver 0.03 (2.4.3)
> Can't claim USB device [0665:5161]: could not detach kernel driver  
> from
> interface 0: Operation not permitted

Any of the USB drivers will have this problem if the permissions are  
not set correctly (although I don't know if the error message is as  
clear in megatec_usb).

I haven't tried Debian squeeze - does it use udev? If so, there should  
be an entry in NUT's udev file that matches your Vendor/Product IDs  

You can also try running it with "-u":

# /lib/nut/blazer_usb -u root -a yukai

It's best to use "-u root" for testing only, though. Debian should be  
setting up a separate user for NUT, and the udev file should set the  
permissions to match.

More information about the Nut-upsuser mailing list