[Nut-upsuser] bcmxcp_usb can not communicate with Eaton Powerware 5110

Massimo Gais simosagi9 at gmail.com
Fri Aug 10 16:26:15 UTC 2012

Hello Arnaud,

thanks for the effort for the patch!

> I took most of this afternoon looking at this issue, and this should be
> fixed with the attached patch
> It applies fine on 2.6.5, using the following command:
> # cd nut-2.6.5
> # patch -p0 < /path/to/xcp-rcv-loop.diff
> # make
> I've tested it on a 5110 only currently, so it's not applied to the
> development tree.
> for testing purpose, I've also used a byte frame size, to be in your
> condition (Ie, set the 4th param of usb_interrupt_read() to '8').
> please tell me back how it behave on RPi.
> note that I'll probably have to do some code adjustment, and obviously
> regression testing on other units, before committing the patch to the main
> source tree.

I applied your patch to the 2.6.5 code and run only the bcmxcp_usb
driver and... I'm not sure that everything is ok.

If I run the driver as "./bcmxcp_usb -u root -a ups" it launches, but
after a second I get a "Communications with UPS lost: get_answer: not
the right sequence received 0!!!". However the driver seems still to
keep running.

I also tried to start the driver under debug (-DDDD). In attachment
you can see the output (until I typed ctrl-c), that also include some
some of the 'communication lost' messages.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: bcmxcp_patched.txt.gz
Type: application/x-gzip
Size: 26404 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20120810/b3d75430/attachment-0001.bin>

More information about the Nut-upsuser mailing list