[Nut-upsuser] Zigor Ebro 650 compatibility

Martyn Hill martyn.joseph.hill at gmail.com
Fri Aug 10 21:54:35 UTC 2012

On 10/08/2012 22:34, Arnaud Quette wrote:
> Aha!
>     I also found a FreeBSD port patch on-line for 2.6.4 that has yet
>     to be committed to the ports-tree. I'll try your route against the
>     latest NUT release and see what we get.
> guys, I've released 2.6.5 yesterday! go the 2.6.5 route ;)

Yeah - saw that, but didn't see any specific changing referencing the 
blazer_usb driver, so haven't tried it yet...
>     I applied the 2.6.4 patch and recompiled and, after chown'ing the
>     USB DEV nodes, got something very similar, effectively, the sequence:
>     Trying megatec protocol...
>     send: Q1
>     read: Unknown error
>     Permissions problem: Input/output error
>     I tried various protocol filters, but only the (new) megatec
>     protocol gets this far...
>         Just for fun, I noticed the #ifdef TESTING in blazer_usb.c.
>         I defined that, and got this output when running ./blazer_usb
>         -a zigor:
>         http://www.bayofrum.net/~crees/scratch/zigor-testing.txt
>         <http://www.bayofrum.net/%7Ecrees/scratch/zigor-testing.txt>
>         Any hints there?
> you've been fooled Chris.
> TESTING just fakes good values for... testing purpose ;)
>     Nice!
>     I then installed the Upsilon s/w on my Windows XP laptop (which
>     works effectively, even if it looks a bit 'old-school'..)
>     I did take some comfort in seeing references to 'Megatec(USB)' in
>     the Upsilon software configuration...
>     I ran USBSniff against the port whilst attaching the UPS.
>     Unfortuately, I couldn't make much sense of the verbose USBSniff
>     output, but if this is useful for debugging (for Arnaud?) I could
>     share it.
> yup, there are not many people left out there, that speak Q1...
> could you please post a link, or a compressed archive (less than 40 Kb!)?

Here's a 6KB rar file of a fresh SniffUSB log file, covering just the 
first minute after plugging-in the UPS to my XP laptop (UPSilon already 
running in Windows System tray).

I've no idea what these 'URB' references are between sections,  but 
around URB 60, I toggled the Beeper and then again around URB 65...

Curiously, the documentation for the Zigor 650 states no Beeper toggle 
ability, but it does work...

Hope that helps - more than happy to carry out further tests and record 
the output, if of any use to you...


"There are 10 types of people in this world. Those who understand binary and those who don't."

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20120810/06dc008b/attachment.html>

More information about the Nut-upsuser mailing list