[Nut-upsuser] Blazer_usb Permissions problem: Input/output error

Paul Barber p at barbz.com.au
Sun Aug 19 07:56:02 UTC 2012

Hi all,

I have an eaton ENV800HA connected for a freebsd 9.0 box with nut 2.6.5 installed (on the supported list).

The UPS is connected using the Blazer_USB driver (not sure how to check its version).

When I kick off upsd it detects the UPS no problems and I get all my information:

battery.charge: 100
battery.voltage: 13.60
battery.voltage.high: 13.00
battery.voltage.low: 10.40
battery.voltage.nominal: 12.0
device.type: ups
driver.name: blazer_usb
driver.parameter.pollinterval: 2
driver.parameter.port: /dev/ugen1.5
driver.version: 2.6.5-Unversioned directory
driver.version.internal: 0.09
input.current.nominal: 3.0
input.frequency: 50.2
input.frequency.nominal: 50
input.voltage: 245.0
input.voltage.fault: 244.5
input.voltage.nominal: 240
output.voltage: 245.0
ups.beeper.status: enabled
ups.delay.shutdown: 30
ups.delay.start: 180
ups.load: 4
ups.productid: 5161
ups.status: OL
ups.temperature: 25.0
ups.type: offline / line interactive
ups.vendorid: 0665

However after a random amount of time I get the following error:
blazer_usb[4466]: Permissions problem: Input/output error

Followed by:
upsd[4468]: Can't connect to UPS [EatonUPS] (blazer_usb-EatonUPS): No such file or directory
upsmon[4566]: Poll UPS [EatonUPS at localhost] failed - Driver not connected
upsmon[4566]: Communications with UPS EatonUPS at localhost lost
upssched-cmd: Communications with the UPS EatonUPS at localhost are lost
upsmon[4566]: Poll UPS [EatonUPS at localhost] failed - Driver not connected

Ive tried the basics and chmod 777'd the ugen1.5 port (not a problem it if works for a while) but worth a shot.

After doing some reading on here I ran /usr/local/libexec/nut/./blazer_usb -u root -DDD -a EatonUPS which on its first run worked for 72 seconds, but 330 seconds on the second run before ending with:

327.930857   send: Q1
 328.193486   read: (247.0 247.0 247.0 004 50.0 13.6 25.0 00001001
 329.940841   send: Q1
 330.177471   read: (247.0 247.0 247.0 004 50.0 13.6 25.0 00001001
 331.950574   send: Q1
 332.193457   read: (247.0 247.0 247.0 004 50.0 13.6 25.0 00001001
 338.860148   send: Unknown error
 338.860204   Permissions problem: Input/output error

Ive also found the following message in the log when I start upsd:
root: Unknown USB device: vendor 0x0665 product 0x5161 bus uhub2

 Any ideas where to go from here?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20120819/74db3308/attachment.html>

More information about the Nut-upsuser mailing list