[Nut-upsuser] CyberPower UPS Help

McCann, Brian bmccann at andmore.com
Wed Feb 15 15:57:59 UTC 2012

Hi all.  I'm trying to get a CyberPower OR700LCDRM1U UPS working with NUT (via USB).  I assumed this would be compatible since the OR2200LCDRM2U is.  Clearly I'm wrong or missing something vital.

I'm on FreeBSD, using the version of NUT from the ports tree (2.6.1).  FWIW, I tried compiling from source with similar results.  Here's my UPS in ups.conf:


And here's the output of 'usbdevs -v':

Controller /dev/usb0:
addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), (0x1166)(0x0000), rev 1.00
 port 1 powered
 port 2 powered
 port 3 powered
 port 4 addr 2: low speed, self powered, config 1, UPS OR700(0x0601), CPS(0x0764), rev 2.00

Additionally, when I plug it in, I get this on the console:

uhid0: CPS UPS OR700, rev 1.10/2.00, addr 2, iclass 3/0

When I try to start, I get this:

Network UPS Tools - UPS driver controller 2.6.1
Network UPS Tools - Generic HID driver 0.35 (2.6.1)
USB communication driver 0.31
No matching HID UPS found
Driver failed to start (exit status=1)

I've tried setting the port to /dev/uhid0, but that didn't help.

Any thoughts anyone?


More information about the Nut-upsuser mailing list