[Nut-upsuser] instaling NUT into OpenWRT: argp-standalone error

kaskada at email.cz kaskada at email.cz
Sat Jan 12 16:38:16 UTC 2013


I`m trying to install NUT on OpenWRT installed at routerboard RB433.

When I run:
opkg install nut

I get this output:

Installing nut (2.6.5-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/nut
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for 
 *      argp-standalone *
 * opkg_install_cmd: Cannot install package nut.

I`ve tried to search solution hard (maybe not hard enough :), but with no 
success. Do you know, what my OpenWRT system really need and where to get 

I`ve also tried to compile NUT right inside OpenWRT in that device (RB433), 
but ./configure script said to me messages, which are in the attechment.

OpenWRT info:
BusyBox v1.19.4 (2013-01-12 00:45:45 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 BARRIER BREAKER (Bleeding Edge, r35097)

Thank you for any advice.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20130112/bac20481/attachment.html>
-------------- next part --------------
root at OpenWrt:/usr/src/nut-2.6.5# ./configure --with-user=ups --with-group=nut --with-usb --with-snmp
Network UPS Tools version 2.6.5
checking build system type... ./config.guess: unable to guess system type

This script, last modified 2011-05-11, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from


If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches at gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2011-05-11

uname -m = mips
uname -r = 3.6.11
uname -s = Linux
uname -v = #2 Sat Jan 12 01:43:13 CET 2013

/usr/bin/uname -p =
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              =
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_VERSION = #2 Sat Jan 12 01:43:13 CET 2013
configure: error: cannot guess build type; you must specify one

More information about the Nut-upsuser mailing list