[Nut-upsuser] Cannot connect to a Eaton Ellipse Pulsar ASR/6000VA usbs [solved] but new problem surfaces.

Charles Lepple clepple at gmail.com
Fri Jun 21 03:02:30 UTC 2013

On Jun 20, 2013, at 10:35 AM, Louis Chaillet wrote:

> With respect clarification of the documentation (and reference to your question Charles). The documentation does suggest that you can shutdown the ups by the upsdrvclt shutdown [ups] command. Specifically in "http://www.networkupstools.org/docs/man/upsdrvctl.html" in the section commands under warning. In the "Network UPS Tools User Manual" (pdf) under section 6.3.2 in the last paragraph it is suggested to first test the /usr/local/ups/bin/upsdrvctl -t shutdown and then "upsmon -c fsd". Also this section suggests that under some circumstances you cannot rely on the shutdown sequence to issue this command.

Thanks, noted.

> However the real reason I tried "upsdrctl -c shutdown" (not the test) is that I  already tested the setup with the "upsmon -c fsd". The results is that the server closes down, as expected, but ups does not shutdown, and so there is no restart of the server.
> I was guessing it has to do with the particular shutdown command of the server I have, which was "SHUTDOWNCMD "/usr/lib/web-admin/backend.pl power_off"". And I was trying to fix that by calling the upsdrvctl shutdown command directly from a script. 
> As I do not use the packaged (debian) shutdown script (/sbin/shutdown) do I need to tell the ups to power down myself, as   suggested in  the documentation (configuration notes, see reference above)?

I haven't traced through the Debian shutdown sequence recently, but I think that they call "upsdrvctl shutdown" after the rest of the system processes have shut down (including the NUT driver). That should avoid the "device or resource busy" error - only one process can open the UPS USB device node at a time.

Charles Lepple

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20130620/05f97f88/attachment-0001.html>

More information about the Nut-upsuser mailing list