[Nut-upsuser] UPS repeater configuration using localhost

Charles Lepple clepple at gmail.com
Tue Sep 17 00:19:42 UTC 2013

[please keep the list CC'd. Thanks!]

On Sep 16, 2013, at 8:11 PM, Derek Rachul <drachul at gmail.com> wrote:

> On Mon, Sep 16, 2013 at 4:36 PM, Charles Lepple <clepple at gmail.com> wrote:
>> On Sep 12, 2013, at 7:47 PM, Derek Rachul <drachul at gmail.com> wrote:
>> > I tried reversing the order of the definitions in the config file, and it does seem to change the order in which they're loaded (at least according to the system logs) however the error remains.
>> I don't have any experience using the dummy-ups driver on the same host as the real UPS driver, so this is a shot in the dark.
>> Can you manually run "upsdrvctl start qnapups"? If it works that way, we may have a race condition in dummy-ups.
> Hi Charles,
> It appears that if I re-run the command above after the main ups driver is running, that the qnapups dummy-ups driver seems to come up, and the target slave seems to be able to connect to it:
> # upsdrvctl start qnapups
> Network UPS Tools - UPS driver controller 2.6.3
> Network UPS Tools - Device simulation and repeater driver 0.12 (2.6.3)
> ...
> Sep 16 17:05:50 upsd[24756]: listening on port 3493
> Sep 16 17:05:50 upsd[24756]: Connected to UPS [ups]: apcsmart-ups
> Sep 16 17:05:50 upsd[24756]: Can't connect to UPS [qnapups] (dummy-ups-qnapups): No such file or directory
> Sep 16 17:05:50 upsd[24757]: Startup successful
> Sep 16 17:05:50 upsd[24757]: User monuser at logged into UPS [ups]
> Sep 16 17:06:10 upsd[24757]: Connected to UPS [qnapups]: dummy-ups-qnapups
> I guess there is some sort of timing considerations there.  Is there any way to delay the loading of a particular UPS driver?

Not within the current framework, as far as I remember. (I think it's just the shutdown order that is configurable.)

What might be better is if the dummy-ups driver tried to reconnect a few times. I haven't really looked at how that might work with the multi-UPS startup code in upsdrvctl, though. upsdrvctl usually waits for some sign of success from each driver. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20130916/6818c2a5/attachment.html>

More information about the Nut-upsuser mailing list