[Nut-upsuser] The dreaded Tripp Lite SMART500RT1U and NUT

Steve Ballantyne steve.ballantyne at gmail.com
Thu Jul 3 15:29:06 UTC 2014

> Lots of good progress here! I tried to enable a few more commands for
> your model. For instance, the "M" values seem to be min/max voltage,
> so there is a "reset.input.minmax" command to use with upscmd.  Also,
> you can trigger a battery test with "test.battery.start". I assume the
> work the same way as on Protocol 3003 :-)

Hello Charles,

The patch that you provided appears to have worked.  The first patch
probably worked too ... but I left the driver running throughout the
rebuilding process (woops).

Some new commands being demonstrated ...
pi at raspberrypi ~/nut $ /usr/local/ups/bin/upscmd -u pi -p pi -l
SMART500RT1U at localhost
Instant commands supported on UPS [SMART500RT1U]:

load.off - Turn off the load immediately
load.on - Turn on the load immediately
reset.input.minmax - Reset minimum and maximum input voltage status
shutdown.return - Turn off the load and return when power is back
test.battery.start - Start a battery test

Doing a test.battery.start definitely works.  CLICK!  BUZZ! BEEP!  Done!

The others give me back an "OK" but do not seem to be doing anything.
Should load.off be shutting down supplied power?  I have a lamp
plugged into the UPS that I have moved around to different ports.  I
have one surge only, one switchable, and then four standard
battery/surge ports.  It doesn't seem to do anything on any of those
ports that I can tell.  If I run it twice, or try to go back and forth
between load.off and load.on, I start generating errors.

pi at raspberrypi ~/nut $ /usr/local/ups/bin/upscmd -u pi -p pi
SMART500RT1U at localhost load.off
Unexpected response from upsd: ERR DATA-STALE
pi at raspberrypi ~/nut $ /usr/local/ups/bin/upscmd -u pi -p pi
SMART500RT1U at localhost load.on
Unexpected response from upsd: ERR DATA-STALE

And then I can't pull down a status ... (at least for a couple of
minutes, and then it will start working again).

pi at raspberrypi ~/nut $ /usr/local/ups/bin/upsc SMART500RT1U at localhost
Error: Data stale

This is what my status dump looks like ...

pi at raspberrypi ~/nut $ /usr/local/ups/bin/upsc SMART500RT1U at localhost
battery.test.status: Battery OK
battery.voltage: 334.10
battery.voltage.nominal: 12
device.mfr: Tripp Lite
device.model: SMART500RT1U
device.type: ups
driver.name: tripplite_usb
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.version: 2.7.2-signed-19-g90e2790
driver.version.internal: 0.26
input.voltage: 0
input.voltage.maximum: 3341
input.voltage.minimum:   0
input.voltage.nominal: 120
outlet.1.desc: Load 1
outlet.1.id: 1
outlet.1.switch: 1
outlet.1.switchable: 1
outlet.2.desc: Load 2
outlet.2.id: 2
outlet.2.switchable: 0
ups.debug.D: 00 7b 00 8b 0d 00 00 '.......'
ups.debug.L: 07 00 00 07 58 58 0d '....XX.'
ups.debug.load_banks: 1
ups.debug.M: 00 74 00 7e 0d 00 00 '.t.....'
ups.debug.P: 30 30 35 30 30 58 0d '00500X.'
ups.debug.S: 01 00 00 00 64 00 0d '....d..'
ups.debug.T: 21 00 02 57 01 58 0d '...W.X.'
ups.debug.V: 02 00 0c 01 58 58 0d '....XX.'
ups.delay.shutdown: 64
ups.firmware: F334401
ups.firmware.aux: protocol 3005
ups.id: 0
ups.mfr: Tripp Lite
ups.model: SMART500RT1U
ups.power.nominal: 500
ups.productid: 0001
ups.status: OL
ups.temperature: 0
ups.vendorid: 09ae

Still have a couple of zeroes in there ... but this is better.  :-)

Steve Ballantyne
Network Engineer
MCSE/MCDST; Novell CLA; LPIC-1; CTT+; A+; Network+; Linux+; Server+;
I-Net+; Security+; SonicWALL CSSA

More information about the Nut-upsuser mailing list