[Nut-upsuser] nutdrv_atcl_usb

jani jani.talikka at gmail.com
Wed Nov 5 06:36:34 UTC 2014

Ok, I installed a fresh Debian testing (jessie) onto a laptop to try making
sure it wasn't my current Ubuntu server causing the issue.  Kernel
is 3.16-3-686-pae #1 SMP Debian 3.16.5-1 (2014-10-10). The only thing
installed besides the stock debian desktop is nut.

The UPS still refuses to talk to the driver, the error messages appear to
be identical, but I attached them just in case I'm missing something
important. I tried changing the permissions and running as root just in
case, and they made no difference.

On 5 November 2014 11:55, jani <jani.talikka at gmail.com> wrote:

> I'm running Ubuntu 14.04.1 LTS with kernel 3.13.0-39-generic x86_64.  The
> security mechanisms I haven't played with at all, and up until last week
> nut was running just fine on an Eaton E series NV UPS with a USB connection
> (from memory it used the blazer_usb driver).  I installed the nut packages
> from debian sid (ubuntu is still stuck on nut version 2.7.1) to get the
> 2.7.2 version with the nutdrv_atcl_usb driver.
> I tried adding the "-u root" to the driver command line, that didn't
> change anything. I might try to find a spare machine to run Debian on to
> see if it works that way.
> On Tue Nov 04 2014 at 3:38:21 PM Charles Lepple <clepple at gmail.com> wrote:
>> On Nov 3, 2014, at 9:01 PM, jani <jani.talikka at gmail.com> wrote:
>> Hello again, I ran the commands again, checking to make sure the UPS was
>> still device 005/002, and the results is:
>>> root at microserver:~# ls -l /dev/bus/usb/005/002
>>> crw-rw-r-- 1 root nut 189, 513 Nov  4 12:55 /dev/bus/usb/005/002
>> I tried setting permissions of /dev/bus/usb/005/002 to 777 and ran the
>> test again to see what that would do, but there was no difference in the
>> status interrupt read error messages.
>> Well, that's odd. Can you provide a little more detail about your system?
>> (distribution, kernel version, any security mechanisms like SELinux or
>> AppArmor, etc.)
>> Also, what happens if you add "-u root" to the driver command line? (The
>> 'chmod 777' should have been sufficient...)
>> --
>> Charles Lepple
>> clepple at gmail
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20141105/8cfb5bdf/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: atcl_logs.tar.gz
Type: application/x-gzip
Size: 2754 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20141105/8cfb5bdf/attachment.bin>

More information about the Nut-upsuser mailing list