[Nut-upsuser] SSL only working in DEBUG mode

Charles Lepple clepple at gmail.com
Fri Mar 13 12:30:14 UTC 2015

On Mar 12, 2015, at 11:55 PM, Melkor Lord <melkor.lord at gmail.com> wrote:

> On Mon, Mar 2, 2015 at 2:39 AM, Charles Lepple <clepple at gmail.com> wrote:
> > I thought start-stop-daemon was involved because it closes stdin/stdout file
> > descriptors after exec()'ing the daemon. I tried "--no-close" option to no
> > avail. After that, I validated the init script working fine with
> > UPSD_OPTIONS="-D" in /etc/nut/nut.conf.
> Not strictly the same as closing the file descriptors, but I tried the
> following:
>   /sbin/upsd -D >/dev/null 2>&1 < /dev/null
> And it still worked. So I need to recompile with debugging symbols -
> the Ubuntu packages did not have them.
> Sorry to bug you again with this issue but is there any improvement on the matter?

No, not yet.

Recompiling with debugging symbols did not reveal anything new. We have reached out to the engineer who wrote the NSS code for NUT.

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list